New owner questions, and amateur radio antenna query
+ Reply to Thread
Results 1 to 3 of 3

This is a discussion on New owner questions, and amateur radio antenna query within the New Member Hangout forums, part of the Community - Meet other Enthusiasts category; Hi all, A couple of weeks ago I purchased a 2010 WRX Sedan (55,000 km on the odo.) and am ...

  1. #1
    Registered User
    Join Date
    Oct 2012
    Posts
    2

    Question New owner questions, and amateur radio antenna query

    Hi all,

    A couple of weeks ago I purchased a 2010 WRX Sedan (55,000 km on the odo.) and am having a great time.

    As a new Subaru owner, I have a couple of questions:
    - Gear shift seems a bit picky about position. From 3rd to 4th is a nice flip down, but most other gears need to a bit of hunting, and/or a bit of pressure to get into. Is this normal? (Clutch seems fine, although a bit heavy.) Getting into reverse seems especially tricky.
    - At (higher) highway speeds the ride feel seems very "floaty". Going over bumps etc., still feels like the car is hunkered down so nothing seems exactly wrong, just feels odd. Is this normal suspension behavior?
    - I'm considering installing a VHF/UHF amateur radio antenna, such as a Comet SBB-5NMO (38"), but am curious to know about others experience with this. As the car is garaged every night, roof mounting is not an option. I'm assuming a fender mount is probably my best option from an installation perspective, though not antenna performance? Any thoughts?

    Thanks.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User nsibanez's Avatar
    Join Date
    Aug 2012
    Location
    Tucson, AZ
    Posts
    1,879
    As far as the shifter, I have the same problem. PITA until warmed up, but then still a bit annoying. Could just be a simple fluid exhange though.

  4. #3
    Registered User
    Join Date
    Oct 2012
    Posts
    2

    60K service coming up

    Quote Originally Posted by nsibanez View Post
    As far as the shifter, I have the same problem. PITA until warmed up, but then still a bit annoying. Could just be a simple fluid exhange though.
    After digging into the Service History, it appears the previous owner didn't get the comprehensive 48K service, so we'll get the car caught up at 60K and I'll ask about the fluid situation. Thanks for the feedback.

    Any thoughts about how you would describe the ride while on a (fast) curvey highway?

    Thanks again.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •