New 2013 Owner with some concerns.
Page 1 of 2 12 LastLast
Results 1 to 15 of 17

This is a discussion on New 2013 Owner with some concerns. within the New Member Hangout forums, part of the Community - Meet other Enthusiasts category; I have had my 2013 5 Door WRX for a little less then a week and I have a few ...

  1. #1
    Registered User
    Join Date
    Aug 2012
    Posts
    37

    New 2013 Owner with some concerns.

    I have had my 2013 5 Door WRX for a little less then a week and I have a few concerns. The car has less then 280 miles on the odometer, I just want to make sure that I'm not getting worked up over something that is normal.

    1.The car pulls to the right almost like it is not aligned properly, I did get brand new tires the day after I got the car but I don't think that those would have caused this issue. (This particular issue I plan on having the dealer fix later this week) But I just wanted to know if other new owners have had this issue.

    2. When turning the steering wheel if it is turned all the way to the left or right with the car moving or not it sounds like the power steering pump is squealling like a pig, now the more you do it the less it happens. Is this something that may go away? Should I have it looked at?

    3.The car idles kind of ruff especially when it is a cold start. Is this typical for the WRX? Should I have this looked at as well?

    Thank you for your help, love the car I drive out of my way where ever I go because I enjoy driving it so much.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User maus's Avatar
    Join Date
    Mar 2012
    Location
    Palm Beach, FL
    Posts
    1,134
    1. Why did you get new ties after the first day of having the car?

    2. I've never heard that on my car

    3. When the car is cold it idles high but it shouldn't be rough
    2012 DGM 5 DOOR WRX
    Mods: Stage 2+
    "I live my life a twelve year old at a time. For those ten seconds or less, I'm free."
    Official ClubWRX Creeper

  4. #3
    Registered User
    Join Date
    Aug 2012
    Posts
    37
    Quote Originally Posted by maus View Post
    1. Why did you get new ties after the first day of having the car?

    2. I've never heard that on my car

    3. When the car is cold it idles high but it shouldn't be rough
    I replaced the summer performance tires with a set of Michelin Pilot Sport A/S plus tires.

  5. #4
    Registered User Soobvirgin's Avatar
    Join Date
    May 2012
    Location
    San Diego
    Posts
    850
    I can't say I've ever heard the steering sound like a squealing pig, but it'll definitely make a noise when put on full lock. Just try to avoid doing that, it puts massive pressure on the power steering pump.... whether moving or not. Although you shouldn't be turning your wheel when you're not moving anyway, you'll wear your tires out. But if you think the noise is excessive, then you should have it checked out at the dealer.

    As Maus says, the engine will idle high when cold but I don't think it should sound "rough". However, my wife's Outback sounds like a bucket of bolts until it warms up. She took it to the dealer and they said it's normal. Huh. I'm not convinced.

  6. #5
    Registered User nsibanez's Avatar
    Join Date
    Aug 2012
    Location
    Bristol, CT
    Posts
    1,227
    As far as the pulling to the right, if it is aligned properly it's going to have something to do with the treads. Maybe you're getting radial pull somehow with brand new tires,or maybe they're directionals put on backwards...I doubt that would do it though.

  7. #6
    Registered User
    Join Date
    Feb 2011
    Posts
    11

    Re: New 2013 Owner with some concerns.

    My 11 was out of alignment when I got it, dealer fixed. I also drove straight to the tire place and had a set of Pilot A/S mounted up, but still needed to have the car aligned at the dealer.
    My steering pump makes a bit of noise at full lock. am the dealer about it when you get your alignment done.

  8. #7
    Registered User
    Join Date
    Aug 2012
    Posts
    37

    New 2013 Owner with some concerns.

    Quote Originally Posted by zipcoolie View Post
    My 11 was out of alignment when I got it, dealer fixed. I also drove straight to the tire place and had a set of Pilot A/S mounted up, but still needed to have the car aligned at the dealer.
    My steering pump makes a bit of noise at full lock. am the dealer about it when you get your alignment done.
    Yeah, they are a awesome tire. I'm going to go to the dealer tomorrow.

  9. #8
    Registered User Ruh Roh's Avatar
    Join Date
    Dec 2011
    Location
    Pottstown PA
    Posts
    3,235
    where did u get the new tires from? were they balanced? and have u owned a subaru before? to me they sound and feel, at idle, different than my older cars because of the boxer engine. you shouldnt have a rough jumpy idle but mine sounds like a mini helicopter warming up in the garage on cold starts lol

  10. #9
    Registered User
    Join Date
    Aug 2012
    Posts
    37

    New 2013 Owner with some concerns.

    Quote Originally Posted by Ruh Roh View Post
    where did u get the new tires from? were they balanced? and have u owned a subaru before? to me they sound and feel, at idle, different than my older cars because of the boxer engine. you shouldnt have a rough jumpy idle but mine sounds like a mini helicopter warming up in the garage on cold starts lol
    Got the tires from belle tire, they are a reputable tire place by me. I haven't owned a subaru before. When I go to the dealer tomorrow to check the alignment I will have them check the other issues.

  11. #10
    Registered User Ruh Roh's Avatar
    Join Date
    Dec 2011
    Location
    Pottstown PA
    Posts
    3,235
    sounds good, whenever you have a problem and your still under warranty take it to the dealer. shouldnt be your worry, but post the problem on here as well so others can help you and give u some direction in what the problem might really be

  12. #11
    Registered User Ruh Roh's Avatar
    Join Date
    Dec 2011
    Location
    Pottstown PA
    Posts
    3,235
    and reading your username im guessing you have a lifted jeep? what kind?

  13. #12
    Registered User
    Join Date
    Aug 2012
    Posts
    37

    New 2013 Owner with some concerns.

    Quote Originally Posted by Ruh Roh View Post
    and reading your username im guessing you have a lifted jeep? what kind?
    I had a 97 Jeep Wrangler TJ, it was one of my favorite vehicles.

  14. #13
    Registered User Ruh Roh's Avatar
    Join Date
    Dec 2011
    Location
    Pottstown PA
    Posts
    3,235
    oh ok nice! ive had a few xj's probably going to make an offroading thread today on here just to see if any other people have trucks and hear their stories

  15. #14
    Registered User
    Join Date
    Aug 2012
    Posts
    37
    **Update**

    Taking the car to the dealership was a nightmare. When I came in for my appointment the service writers and the Subaru Technician were on the defensive telling me that the car will normally pull to the right due to the crown of the road and it being such a light vehicle, I dont think that the vehicle should change lanes on its own on the freeway to. To make matters worse the tech decided that it was the tires that I had on the vehicle and that those were to blame for the pull to the right. But for some reason he decided to flip the front drivers and passengers tire any ways because he believed they were the source of the problem. While doing that he scratched the factory rims and what ever tool they used also made a ring on the inside of each lug hole on my brand new rims.

    I'm not really sure where to go from here, they are pointing the finger at my tires and are basically telling me go fly a kite even though the car has less then 500 miles on it. I also need to bring up the damage to the wheels what is the best way to go about doing this?

    Thanks in advance

  16. #15
    Registered User jilty's Avatar
    Join Date
    Aug 2012
    Location
    Southern California
    Posts
    90
    I got my 2013 5day about 4 weeks ago almost.

    1. My car has a very very slight pull, I am guessing from the road pitch. Other than that, on a freeway or whatever, pretty straight and true it seems.

    2. I have heard the same noise, I have never kept it pinned all the way into a turn, but I have had spots where I needed to turn all the way, and there is a slight noise, but only for a second, then its not needed to turn so sharpy.

    3. My idle is horrible, not just cold start. When sitting in traffic (I live in So Cal, right outside of Los Angeles) I have thought my car would die the idle was so rough and low at times. In the morning, its about 50 degrees and my idle is normal after the engine warms up after a few seconds. Sometimes when I take off from a stop it drops insanely low after a second and then picks up. My buddies 2011 does not do this at all and I have driven it and inside it a few times. Maybe its how the 13s are, so come on Cobb and get those 2013 maps out!!

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •