1st Subaru... 2002 WRX 2.0 Turbo - Page 2
Page 2 of 2 FirstFirst 12
Results 16 to 20 of 20

This is a discussion on 1st Subaru... 2002 WRX 2.0 Turbo within the New Member Hangout forums, part of the Community - Meet other Enthusiasts category; Originally Posted by Velislide I noticed the temp gauge doesn't work. I wonder if it's possible to changing the crappy ...

  1. #16
    \_(ツ)_/ Rambo's Avatar
    Join Date
    Oct 2010
    Location
    Portland, OR
    Posts
    5,012
    I Support ClubWRX
    Quote Originally Posted by Velislide View Post
    I noticed the temp gauge doesn't work. I wonder if it's possible to changing the crappy yellow light inside the boost gauge console, into a green tone light to match the rest.
    Should be easy enough. The factory gauges use incandecent bulbs with rubber "condoms", so to speak. They should have appeared green stock, but I'm guessing they've worn away over the years.
    Isaac -- 2003 WRX sedan Stg II - Gave its life for mine 6/2013.
    2007 Outback 3.0R wagon
    Proud owner of a N.E.R.D, Member 1.3810-23

    The pursuit of knowledge is hopeless and eternal... Hooray!!! - Professor Farnsworth

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #17
    Registered User Phobic's Avatar
    Join Date
    Aug 2012
    Location
    Boston, Ma
    Posts
    566
    mine just came with a boost gauge on the steering column. better than nothing haha

  4. #18
    zax
    zax is offline
    \_(ツ)_/ zax's Avatar
    Join Date
    Nov 2008
    Location
    Neverland Ranch, Maryland
    Posts
    13,158
    I Support ClubWRX I Support ClubWRX

    Re: 1st Subaru... 2002 WRX 2.0 Turbo

    They are not "stock" but they were a dealer installed option available from SOA.

    Sent from my DROID BIONIC using Tapatalk 2
    2015 CWP WRX STi ... But how did I get roped back into an EJ motor?!
    Zax's utterly unimaginably stock 2015 STi build thread
    Zax's Shaggin' Wagon Build Thread Now tuned for 99% pure Unicorn Jizz!

    Zach | Moderator -- Mid-Atlantic States, Tech & Modifying & General Repairs
    Rollin' with the Bugeye Mafia #302 | N.E.R.D. Subject Zero
    Facebook me here

    Your Mid-A local board: http://www.clubwrx.net/forums/mid-atlantic-states/

  5. #19
    Registered User
    Join Date
    Sep 2012
    Posts
    17
    Hmmm, new issue popped up. The idle seemed rough since I got the car, and the engine light came on while letting it idle for about 5 minutes. Misfire on cylinders 1, 2, and 3. I cleaned the MAF yesterday and it seemed to idle better, but now today it is idling rough again. It drives normal, pulls hard and smooth, no hiccups.

  6. #20
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,726
    I Support ClubWRX

    1st Subaru... 2002 WRX 2.0 Turbo

    See the misfire code sticky thread.
    WRX Info Links, Courtesy TheJ
    Man is a brute.... If you're cruel to him, he respects and fears you. If you're kind to him, he plucks your eyes out. Alexis Zorbas
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •