06 STi (Help)
Results 1 to 6 of 6

This is a discussion on 06 STi (Help) within the New Member Hangout forums, part of the Community - Meet other Enthusiasts category; The other day i was backig out of my drive-way, and i heard a belt squeel. Took the cover off ...

  1. #1
    Registered User DiRty Impreza's Avatar
    Join Date
    Jun 2011
    Location
    Canton, Ohio
    Posts
    207

    06 STi (Help)

    The other day i was backig out of my drive-way, and i heard a belt squeel. Took the cover off to see the P/S belt was loose, and the adjustment was just hanging there. So i tightened the P/S belt. Drove fine, parked it for the night. This morning i start the car up, 06 STi that is, and the check engine light was on, cruise control was flashing. Popped the hood and i could kind of hear a whinding noise from P/S belt. Did i over-tighten the belt? why would that throw a code? and why is cruise control flashing?
    ++ + ++P3LLA++ + ++

    06 STi ( Stage II ) BOOSTED
    HAWK-EYE ALLIANCE # 808

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User Mike193's Avatar
    Join Date
    Nov 2011
    Location
    North Jersey
    Posts
    966
    1. No idea why code was thrown.

    2. Most, (if not all) of our cars have that feature where when a CEL is thrown, the car automatically blinks cruise and drive like a slug. (In my friends F-150 this is called 'Limp-home mode')

  4. #3
    Sammich Makin' Pwincess wrxtreme06's Avatar
    Join Date
    May 2007
    Location
    orlando flawduh
    Posts
    12,723
    I Support ClubWRX
    the CEL could be related, or it could be coincidental. we cant help unless we know the code

    desiree
    your friendly, neighborhood subaru girl
    abbigale : 06 impreza wrx tr: cobb stage II
    hawkeye alliance #11:11//
    wingl3ss @ll!ance #17 // lvl 80 N.E.R.D.

  5. #4
    Registered User Mike193's Avatar
    Join Date
    Nov 2011
    Location
    North Jersey
    Posts
    966
    Quote Originally Posted by wrxtreme06 View Post
    we cant help unless we know the code
    Autozone or (I believe) Pep Boys, will run the code, for free and on the spot.

  6. #5
    Registered User DiRty Impreza's Avatar
    Join Date
    Jun 2011
    Location
    Canton, Ohio
    Posts
    207
    i've got my own scanner, just didn't have time to read code. hoping it was something simple somebody else ran into when changing belts. Im running home at lunch to read the code or codes, then i will post them. Any insight is appriciated.
    ++ + ++P3LLA++ + ++

    06 STi ( Stage II ) BOOSTED
    HAWK-EYE ALLIANCE # 808

  7. #6
    Registered User DiRty Impreza's Avatar
    Join Date
    Jun 2011
    Location
    Canton, Ohio
    Posts
    207
    so i tried to pull the codes with my obdII scanner, and my cobb access port. Kept reading (KWPadd) (KWP2) code error. obdII scanner worked on my old 02 WRX, and my buddy's 08 WRX tonight just fine reading wastegate and turbo codes because of his aftermarket exhaust and intake. but no codes for me. so i figured light didn't come on until i tightened p/s belt, so i loosened it slightly. start the car up check engine light is gone. EXTREMELY ODD, called my subaru tech and the dealer, never heard of it. i know the codes still have to be stored in there. im just gona go to subaru and have them pull it, because im curious now. Anybody has helpful information, please reply.
    ++ + ++P3LLA++ + ++

    06 STi ( Stage II ) BOOSTED
    HAWK-EYE ALLIANCE # 808

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •