hi every body. cant get my beast to start it cranks but wont fire up.
+ Reply to Thread
Results 1 to 5 of 5

This is a discussion on hi every body. cant get my beast to start it cranks but wont fire up. within the New Member Hangout forums, part of the Community - Meet other Enthusiasts category; Its getting fuel and spark but wont start.if i put fuel in the throttle it starts. any suggestions....

  1. #1
    Registered User
    Join Date
    Dec 2011
    Location
    sydney aus
    Posts
    2

    Red face hi every body. cant get my beast to start it cranks but wont fire up.

    Its getting fuel and spark but wont start.if i put fuel in the throttle it starts. any suggestions.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,980
    I Support ClubWRX
    Fuel pressure regulator? Please list modifications, any recent changes etc. for better troubleshooting.
    WRX Info Links, Courtesy TheJ
    Man is a brute.... If you're cruel to him, he respects and fears you. If you're kind to him, he plucks your eyes out. Alexis Zorbas
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  4. #3
    Registered User
    Join Date
    Oct 2011
    Posts
    26
    Like the other guy said, check fuel pressure. Maybe the timing is off?

    Sent from my SGH-T959 using Tapatalk

  5. #4
    Registered User
    Join Date
    Dec 2011
    Location
    sydney aus
    Posts
    2

    i bought the sti recently.

    When i bought the 2002 sti it had front end damage and minor parts on engine were broken and cracked. i replaced crank pulley it was bent,timing was still ok but i replaced timing belt and re did the timing.intake manifold was cracked so i rplaced it.altenator.power steering pump.and air con was replaced.also replaced exshaust headers they were damaged aswell.. mods that have been done by previous owner are ej25 forged rebuilt motor,bigger fuel pump,bigger injectors,exhaust headers and full exhaust, bigger oil cooler,52 mm radiator, aps sr55 turbo,bigger air intake,ecutek flashtune.. so you think fuel pressure regulator do you mean the one thats next to fuel filter or else. ??

  6. #5
    Registered User
    Join Date
    Nov 2011
    Location
    Pittsburgh, PA
    Posts
    36
    I recently had the same problem with my jeep. I removed the throttle body and cleaned it and cleaned the IAC. I don't know whether the subies have throttle bodies, but I imagine that they would. It seems to have fixed the problem, and now with my "custom" intake, it kind of whistles like I have a turbo.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •