Help
+ Reply to Thread
Results 1 to 6 of 6

This is a discussion on Help within the New Member Hangout forums, part of the Community - Meet other Enthusiasts category; Hi, New to this site. I just replaced the up pipe and down pipe on my daughter's '02 WRX. I ...

  1. #1
    Registered User
    Join Date
    Aug 2011
    Posts
    4

    Help

    Hi,
    New to this site. I just replaced the up pipe and down pipe on my daughter's '02 WRX. I did have to remove the turbo to cut off two bolts. Anyway now engine light is on and is appears to be dripping antifreeze from the lower part of the up pipe??? Any suggestions?

    Thank you Ron

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    OMG WTF MainFrame's Avatar
    Join Date
    Sep 2002
    Location
    Texas, United States
    Posts
    8,713
    I Support ClubWRX I Support ClubWRX
    If you didn't tune it, or use the resistor mod for the EGT sensor in the uppipe, that would be why the CEL is on.


    Now dripping antifreeze is a whole other thing. I would double check where the water line attaches to the turbo.. something may have got messed up there when you removed/replaced the turbo. On a nearly ten year old car worn out lines tend to break/tear easily.

  4. #3
    Registered User
    Join Date
    Aug 2011
    Posts
    4
    Quote Originally Posted by MainFrame View Post
    If you didn't tune it, or use the resistor mod for the EGT sensor in the uppipe, that would be why the CEL is on.


    Now dripping antifreeze is a whole other thing. I would double check where the water line attaches to the turbo.. something may have got messed up there when you removed/replaced the turbo. On a nearly ten year old car worn out lines tend to break/tear easily.

  5. #4
    Registered User
    Join Date
    Aug 2011
    Posts
    4
    Thanks! Looks like the drip stopped.... Some smoke in the engine probably from never sieze and penetrating stuff.
    Smoke from the engine when you rev it up. Is that normal because of all the changes?

    Thanks again!! Ron

  6. #5
    OMG WTF MainFrame's Avatar
    Join Date
    Sep 2002
    Location
    Texas, United States
    Posts
    8,713
    I Support ClubWRX I Support ClubWRX
    Depends on how much smoke.. every time I change to a new exhaust I notice some smoke, especially if it's wrapped. The smoke should clear up after one good drive though. If it continues smoking you might still have a leak somewhere.

  7. #6
    Registered User
    Join Date
    Aug 2011
    Posts
    4

    Boost Leak

    Hi,
    Looks like from reading on line I have a Boost leak. How do you check it from home? White smoke and coolant leaking from the exhaust.

    Thank you, Ron

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •