03 WRX with issues......
+ Reply to Thread
Results 1 to 10 of 10

This is a discussion on 03 WRX with issues...... within the New Member Hangout forums, part of the Community - Meet other Enthusiasts category; So, about 6 months ago I finally purchased my first SUBIE!!! Love the car, but as with any used car ...

  1. #1
    Registered User
    Join Date
    Jul 2011
    Location
    Algonquin, IL
    Posts
    5

    03 WRX with issues......

    So, about 6 months ago I finally purchased my first SUBIE!!! Love the car, but as with any used car it came with its own issues. This car has a Jap. spec motor in it, not the one you get here in the states(guy had it shipped) it has about 50k on the motor. No problem there. However, the car sat for 2 years before I bought it (or stole it actually) I paid next to nothing for the car and was aware that it needed to have the head gaskets done. No problem there either. Had the car fixed by a great SUBIE guy and I LOVE IT!!! I think it's the best car I've ever bought..... now comes the issue.... I have what I call a hesitation, in any gear, but usually at about 2-2.5 rpms. this is not a hesitation on acceleration, but at a steady speed. I'm not exactly retarded when it comes to cars( I was married to a mechanic for 13 yrs.) you pick up a few things. It's not a clutch issue, I know what that feels like. It seems to act up more when the car is warm, after about 15 - 20 miles are put on it. I've never had a car do this. Can ANYONE give me ANY idea where to start, this is driving me CRA-Z!!!!

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User metaldahlberg's Avatar
    Join Date
    Sep 2010
    Location
    NH
    Posts
    813
    I'm not sure what you mean by "hesitation at a steady speed". Can you try to explain more?
    Contributing unsolicited, worthless opinions since 9/10...
    The project I spend all my money on.... <---- Click it

  4. #3
    Registered User
    Join Date
    Jul 2011
    Location
    Algonquin, IL
    Posts
    5
    I figured I'd get that question.....I don't know... I guess the best way to describe it is that it feels like your tapping on the brakes very lightly. It doesnt affect the rpms at all and it's not a brake hang up, just had them checked.

  5. #4
    Registered User metaldahlberg's Avatar
    Join Date
    Sep 2010
    Location
    NH
    Posts
    813
    So the rpms/speed don't change when you feel it happen?
    Contributing unsolicited, worthless opinions since 9/10...
    The project I spend all my money on.... <---- Click it

  6. #5
    Registered User
    Join Date
    Jul 2011
    Location
    Algonquin, IL
    Posts
    5
    nope, not at all. That's the first thing I looked at. Really....I'm not nutz! passengers have felt it too.

  7. #6
    Banned
    Join Date
    Aug 2008
    Location
    Davey Jones Locker
    Posts
    8,644
    I Support ClubWRX
    Manual or automatic?

  8. #7
    Registered User
    Join Date
    Jul 2011
    Location
    Algonquin, IL
    Posts
    5
    manual of course....is there any other kind???? not for me......

  9. #8
    Registered User
    Join Date
    Jul 2011
    Location
    Algonquin, IL
    Posts
    5
    I thought maybe a fuel system issue... nope, cleaned and flushed the system and changed the filter. Still no fix!

  10. #9
    Registered User SKI.WRX's Avatar
    Join Date
    Jun 2010
    Location
    Colorado
    Posts
    333
    Does it happen without the AC on? In my car I can feel when the AC compressor kicks in at lower rpms which feels similar to what you are describing. Almost a light touch on the brakes. At higher rpms or in boost i don't really notice it but perhaps that is your issue.

    Is there a CEL? Another friend of mine got a hesitation like that that only appeared when acceleration hard. turned out to be a bad cat.

  11. #10
    Registered User Monk_Knight's Avatar
    Join Date
    Aug 2010
    Location
    Colorado
    Posts
    553
    I have experienced a similar sort of "hesitation" in my 03 WRX recently. Usually happens when I'm accelerating moderately in 2nd gear or in 4th where I'm just barely accelerating. Usually felt like a bit of a stutter... pretty hard to describe really. Sounds similar to what you were describing though it happened at different times for me.
    Since it wouldn't happen too often I wasn't worrying about it much.

    But today when it was in the shop getting a new downpipe put on, the shop owner said he found that the line going to the boost solenoid was broken (or something like that). He fixed it while he was in there and the hesitation is gone. Might be worth a check.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •