need some help
Results 1 to 4 of 4

This is a discussion on need some help within the New Member Hangout forums, part of the Community - Meet other Enthusiasts category; goin to get a 02 wrx, but... The boost will cut out in high boost(15psi).. spools up and started to ...

  1. #1
    Registered User
    Join Date
    May 2011
    Posts
    2

    need some help

    goin to get a 02 wrx, but... The boost will cut out in high boost(15psi).. spools up and started to jet then all boost is gone, then it all comes back. any ideas?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,289
    I Support ClubWRX
    In the maintenance forum, post your list of modifications and any other info about the car that would be useful. Include any changes made and when it started the problem.
    WRX Info Links, Courtesy TheJ
    The world breaks everyone and afterward many are strong in the broken places. Ernest Hemingway
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  4. #3
    Registered User
    Join Date
    May 2011
    Posts
    2
    Cool thanks

  5. #4
    Registered User batorr's Avatar
    Join Date
    May 2011
    Location
    Rochester, New Hampshire, United States
    Posts
    62
    could be the turbo. mine did that when the seal inside went (everything was stock at the time). if you remove the top mount intercooler and look inside it and find a lot of oil then that may be your problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •