'10 WRX - engine light & cruise control flashing
Page 1 of 2 12 LastLast
Results 1 to 15 of 29

This is a discussion on '10 WRX - engine light & cruise control flashing within the New Member Hangout forums, part of the Community - Meet other Enthusiasts category; A few days ago I was driving on the interstate and suddenly my check engine light came on and my ...

  1. #1
    Registered User jlinnell98's Avatar
    Join Date
    Feb 2010
    Location
    Iowa
    Posts
    107

    '10 WRX - engine light & cruise control flashing

    A few days ago I was driving on the interstate and suddenly my check engine light came on and my cruise light started flashing. It also stuck the traction control light on (push the button and nothing happened, it just kept the trac control off).

    My car has about 10K on it and the only mod is a factory installed SPT exhaust. I've heard of people having a similar issue when installing some aftermarket parts, but never with just an SPT CBE. Anyone have this issue that has a 09/10 stock WRX? It stayed on even after letting the car sit (I was on my way to work) and had to disconnect the neg battery cable, then everything went back to normal. Any thoughts/suggestions would be helpful!

    Thanks

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Captain James of the SS Impreza has gone down with the ship Drews's Avatar
    Join Date
    Aug 2008
    Location
    Davey Jones Locker
    Posts
    8,489
    I Support ClubWRX
    Should have gotten the code pulled while it was on. Oh wells...if it doesn't come back sweet, if it does I'd take it and figure out what code its throwing.
    Hawk-Eye Alliance #Eleventy,000,000,000|N.E.R.D. Member 20,000
    Stable: 2014 Hyundai Veloster Turbo (Matte Grey), 06 LGT, 03 WRX, 98 RS, 00 OBS


    Resident Clubdub Debbie Downer. I'd love your ideas if you kept them to yourself. Subarus suck, get a new wife.

    Never argue with idiots. They'll drag you to their level and beat you with experience.

  4. #3
    Registered User WillieRX's Avatar
    Join Date
    Nov 2010
    Location
    CO Mountains
    Posts
    302
    Is it just me, or am i seeing quite alot of issues with the 08+ Imprezas?
    2006 Subaru WRX TR (Weekend Warrior)
    1993 Ford F250 Diesel (Daily Work Commuter)
    Hawk-Eye Alliance #9455
    My WRX Mods

  5. #4
    Registered User dbya rx's Avatar
    Join Date
    Jul 2010
    Location
    San Marcos, California, United States
    Posts
    911
    my suggestion is if it happens again, call subaru roadside assistance immediately, have them tow your car to the nearest dealership, pickup a loaner, and have them figure it out for free, which is why you have warranty.

    /winning
    Stink-eye Mob #814004
    2010 WRX Limited Hatch - spt short throw...for now

  6. #5
    Black Wind KazeVelara's Avatar
    Join Date
    Feb 2009
    Location
    Ashland PA
    Posts
    367
    I Support ClubWRX
    What were you doing specifically when it came on? It sounds like it went into limp mode, I usually have that issue when the car over-boosts, but with only the SPT? Hm...
    2011 Black STI Sedan "Shadow"
    RIP Colin McRae
    http://s346.photobucket.com/albums/p418/kazevelara/
    Stink-Eye Mob #43
    "Trust in The Armin"

  7. #6
    Registered User Nebuka's Avatar
    Join Date
    Feb 2011
    Posts
    58
    Quote Originally Posted by dbya rx View Post
    my suggestion is if it happens again, call subaru roadside assistance immediately, have them tow your car to the nearest dealership, pickup a loaner, and have them figure it out for free, which is why you have warranty.

    /winning
    Would we also get a loaner for free?

  8. #7
    Registered User 06scoobyrex's Avatar
    Join Date
    Feb 2010
    Location
    SL,UT
    Posts
    2,606
    Yes you would get a free loaner assuming SOA picks up the tab for the repair and the job is more then ~5 hours of labor... I have very little faith in SOA's warranty coverage, but that is my own opinion...
    Hawk-Eye Alliance #801
    The Impreza "this was repaired/replaced at what mileage" database (Please Contribute)
    http://www.clubwrx.net/forums/showth...57#post2688257

  9. #8
    Registered User wrxrachy917's Avatar
    Join Date
    Apr 2011
    Location
    Fort Collins, Colorado
    Posts
    41
    I had the same exact thing happen to me. I have an '11 and after only 200 miles those three lights came on. I took it to the dealer and they could find nothing wrong with it so they just reset the lights and I haven't had it happen since. So I don't think its anything serious...
    Rachelle
    2011 DGM WRX Hatch
    Stink Eye Mob #970

    Facebook link

  10. #9
    Registered User jlinnell98's Avatar
    Join Date
    Feb 2010
    Location
    Iowa
    Posts
    107
    Quote Originally Posted by KazeVelara View Post
    What were you doing specifically when it came on? It sounds like it went into limp mode, I usually have that issue when the car over-boosts, but with only the SPT? Hm...
    Getting on the interstate, barely in boost so not sure why it happened

  11. #10
    Registered User jlinnell98's Avatar
    Join Date
    Feb 2010
    Location
    Iowa
    Posts
    107
    Quote Originally Posted by wrxrachy917 View Post
    I had the same exact thing happen to me. I have an '11 and after only 200 miles those three lights came on. I took it to the dealer and they could find nothing wrong with it so they just reset the lights and I haven't had it happen since. So I don't think its anything serious...
    That makes me feel better. Thanks!

  12. #11
    The Fruit mangostick's Avatar
    Join Date
    Oct 2009
    Location
    VB VA .. the ghetto on the sea
    Posts
    4,735
    Quote Originally Posted by WillieRX View Post
    Is it just me, or am i seeing quite alot of issues with the 08+ Imprezas?

    45k mi on my '10 .. no issues. Dunno whatcha talkin bout willis.. lol
    OBP 2010 5dr *traded*
    SWP 2013 FRS
    My name is Shawn, I'm a Devout Practicalist and I'm addicted to flat4's
    This page has had 1,666 visits
    SUCH IS MANGO!

  13. #12
    Registered User KingTurbo's Avatar
    Join Date
    Apr 2011
    Location
    Pittsburgh
    Posts
    7
    OK, So this same thing happened to me today on my 11 WRX today. It's the second time! I'm stuck with a crappy rental til they figure out the problem.

  14. #13
    Registered User nyr8er's Avatar
    Join Date
    Feb 2011
    Location
    Cambridge, NY
    Posts
    442
    same thing happened to me after i did my Kartboy install but it was COMPLETELY MY FAULT. when i jacked the car up and got under it, there is a cable that goes right under the shift linkage. i disconnected it for easy access to the linkage and all the bushings. then i got busy with the rest of the install, drinking with a buddy in his garage and putting (almost) everything back together.

    i left the next morning and all the same lights were on and as soon as i noticed, i knew exactly what it was and pulled right back into his garage. i plugged it back in and all the lights went away. don't know if it'll help but that's what happened to me.
    2011 WRX Base Hatch in Obsidian Black Pearl
    Stink-Eye Mob #027
    My Car
    - Mike

  15. #14
    Registered User KingTurbo's Avatar
    Join Date
    Apr 2011
    Location
    Pittsburgh
    Posts
    7
    I hope that's it nyr8er. I know my car came with the STI short shifter, the same thing could've happened during the install. I'll ask the dealer to check the cable tomorrow. Thanks!

  16. #15
    Moderator rage-wrx's Avatar
    Join Date
    Aug 2010
    Location
    Yonkers/NYC
    Posts
    10,761
    I Support ClubWRX
    You guys are talking about a disconnected O2 sensor?
    T0ny
    2011 WRX
    2012 FXT

    The Big 2011/2012 Mod Thread


    Ooh,hang on. That is the throb of a turbocharged flat four engine. A sound which,all over the world,heralds the imminent arrival of a moron - JC.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •