Check Engine, Traction Control, Cruise Control Faults
+ Reply to Thread
Results 1 to 3 of 3

This is a discussion on Check Engine, Traction Control, Cruise Control Faults within the New Member Hangout forums, part of the Community - Meet other Enthusiasts category; WRX Forum, I've been getting all three faults simultaneously: check engine, cruise cuise control (doesn't work, the light keeps blinking ...

  1. #1
    Registered User
    Join Date
    Jul 2010
    Posts
    5

    Check Engine, Traction Control, Cruise Control Faults

    WRX Forum,

    I've been getting all three faults simultaneously: check engine, cruise cuise control (doesn't work, the light keeps blinking on and off), and traction control light comes on and will not work.

    The diagnostic machine reads the check engine fault as O2 sensor bank 1, sensor 1.

    My battery died last week so I replaced it. This cleared all the codes for about 300 miles and all three faults returned.

    I tested the battery and it said it needed to be charged. This is a one week old battery. I removed the battery from the car and tested it and it was 100% good. The alternator is also 100% good.

    I'm guessing there may be an issue with the terminals. I do have a problem with one of the terminals; the terminal is too small for the clasp that goes around the terminal. Meaning when I tighten the clasp down it is still loose and can be pulled right off the terminal with ease. I temporarily have a small screw between the terminal and the clasp so the clasp can tighten and not come off so easy.

    I do have the replacement bank 1 sensor 1 oxygen sensor and plan on getting that installed. Any suggestions on the battery issue?

    Thanks in advance.
    aeyr

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User oguitar's Avatar
    Join Date
    Nov 2009
    Location
    Albuquerque, New Mexico, United States
    Posts
    1,021
    Is this even the right battery for the car?
    Life is like riding a bicycle in order to keep your balance you must keep moving.

  4. #3
    Registered User teflon_jones's Avatar
    Join Date
    Apr 2007
    Location
    8000' up in Colorado
    Posts
    6,753
    I don't understand how a clamp doesn't fit a terminal. Terminals are a standard size.....

    +1 to what oguitar said.
    Scott
    Past Subies - '11 STI Limited stage 1+ and '04 STi stage 2+
    '13 Wrangler Rubicon - custom front bumper w/12k lb winch & off-road lights, skid plates, diff guards, etc.
    '04 Porsche 911 Turbo GT2 clone 600 HP/TQ
    '77 F-150 heavily modded for off-roading

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •