new car problem
Results 1 to 6 of 6

This is a discussion on new car problem within the New Member Hangout forums, part of the Community - Meet other Enthusiasts category; I just bought a 2006 subaru wrx and as far as I know it is running at 20psi with a ...

  1. #1
    Registered User
    Join Date
    Jan 2011
    Location
    currently in pensacola fl.
    Posts
    3

    new car problem

    I just bought a 2006 subaru wrx and as far as I know it is running at 20psi with a aftermarket intercooler, 3" turbo back exhaust, 750cc injectors with an ecu reflash down at fl. central turbo. The engine light is on and not blinking ,but the cruise control light is blinking the owner told me that it was because he never upgraded the MAF and that the air/fuel is right it just needs a new MAF sensor.Any idea what would be good for my set-up?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User
    Join Date
    Jan 2011
    Location
    currently in pensacola fl.
    Posts
    3
    So will a new MAF sensor mess with my air fuel ratio or will I have to get a reflash done again.

  4. #3
    Registered User lytlec's Avatar
    Join Date
    Jan 2009
    Location
    Central PA
    Posts
    4,300
    Go get the CEL read with a code reader.
    <-------- Taylor Swift.
    2006 WRX 330whp. 300wtq. Slow.
    Hawk-Eye Alliance #137
    First Mods...what to do.
    Subaru Guide

  5. #4
    Registered User metaldahlberg's Avatar
    Join Date
    Sep 2010
    Location
    NH
    Posts
    813
    Have you tried cleaning the maf?
    Contributing unsolicited, worthless opinions since 9/10...
    The project I spend all my money on.... <---- Click it

  6. #5
    Registered User jd92677's Avatar
    Join Date
    Jul 2010
    Location
    Cincinnati
    Posts
    2,136
    Quote Originally Posted by bleau42 View Post
    I just bought a 2006 subaru wrx and as far as I know it is running at 20psi with a aftermarket intercooler, 3" turbo back exhaust, 750cc injectors with an ecu reflash down at fl. central turbo. The engine light is on and not blinking ,but the cruise control light is blinking the owner told me that it was because he never upgraded the MAF and that the air/fuel is right it just needs a new MAF sensor.Any idea what would be good for my set-up?
    The tune should have taken into account the MAF that was on the car. I would have the code read before anything else.

  7. #6
    Subaru Newb MainFrame's Avatar
    Join Date
    Sep 2002
    Location
    Texas, United States
    Posts
    8,043
    I Support ClubWRX I Support ClubWRX
    Why does it need a new MAF? The one that's on there should be fine, unless it's damaged or something.



    You should pull the code so you know what caused the CEL to come on.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •