Check Engine Light and Cruise Light Blinking???
Results 1 to 9 of 9

This is a discussion on Check Engine Light and Cruise Light Blinking??? within the New Member Hangout forums, part of the Community - Meet other Enthusiasts category; Can removing the big Intake Silencer white thing throw a check engine light code and cause the cruise light to ...

  1. #1
    Registered User
    Join Date
    Nov 2010
    Location
    Maryland
    Posts
    109

    Check Engine Light and Cruise Light Blinking???

    Can removing the big Intake Silencer white thing throw a check engine light code and cause the cruise light to blink????

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User
    Join Date
    Nov 2010
    Location
    Maryland
    Posts
    109
    This is what I removed except mine was white???

  4. #3
    Registered User mudferret's Avatar
    Join Date
    Aug 2009
    Location
    Canada/Ethiopia/Madagascar
    Posts
    1,979
    It shouldn't. For starters ensure that your airbox is put back together correctly, and your MAF was reinstalled (if you had removed it) in the correct orientation (plug facing front of car).

    Then go get the code read.
    ...Rob.
    MMVI WRX - VF43 Airboy Tuned @ 3500'

  5. #4
    Registered User teflon_jones's Avatar
    Join Date
    Apr 2007
    Location
    8000' up in Colorado
    Posts
    6,753
    Is the CEL blinking, or just the cruise?

    Never drive a car with a blinking CEL. That's the idiot light telling you "Don't drive me! I've got serious issues!"
    Scott
    Past Subies - '11 STI Limited stage 1+ and '04 STi stage 2+
    '13 Wrangler Rubicon - custom front bumper w/12k lb winch & off-road lights, skid plates, diff guards, etc.
    '04 Porsche 911 Turbo GT2 clone 600 HP/TQ
    '77 F-150 heavily modded for off-roading

  6. #5
    Registered User
    Join Date
    Nov 2010
    Location
    Maryland
    Posts
    109
    No the check engine light is stating on solid but the cruise light it blinking now. The MAF Sensor is in place correctly, and the intake box is down properly. I did read online though that if the MAF sensor is unplugged then plugged back in it will throw a CEL code for awhile. It said to unplug the battery for 10 minutes???? And it should reset?? Anyone ever have this happen?

  7. #6
    Registered User mudferret's Avatar
    Join Date
    Aug 2009
    Location
    Canada/Ethiopia/Madagascar
    Posts
    1,979
    Get the code read before you disconnect the battery, it could save you a lot of trouble, and possibly a lot of expense.

    I noticed you mentioned you were having boost loss issues in another thread, don't do anything else to the car until you get that and this issue figured out, for each additional thing you do to your car the waters just get muddier.
    ...Rob.
    MMVI WRX - VF43 Airboy Tuned @ 3500'

  8. #7
    Registered User
    Join Date
    Nov 2010
    Location
    Maryland
    Posts
    109
    Quote Originally Posted by mudferret View Post
    Get the code read before you disconnect the battery, it could save you a lot of trouble, and possibly a lot of expense.

    I noticed you mentioned you were having boost loss issues in another thread, don't do anything else to the car until you get that and this issue figured out, for each additional thing you do to your car the waters just get muddier.
    Gotcha, yea My secondary Air Inject Pump went up about a month ago and the dealer had that replaced. And now I have a serious boost leak I guess somewhere, I'm running around .04mpa MAX, and now after I removed the Silencer my check engine light popped on now and my cruise light is blinking.

  9. #8
    Registered User
    Join Date
    Nov 2010
    Location
    Maryland
    Posts
    109
    I will go get it read today here soon and post up what the code is for.

  10. #9
    Registered User
    Join Date
    Nov 2010
    Location
    Maryland
    Posts
    109
    So my CEL is off now today and all is good. That's weird huh? I think it was from me unplugging my MAF Sensor and plugging it back in.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •