Just bought 1st bugeye lots of mods but boggs down
Page 1 of 2 12 LastLast
Results 1 to 15 of 26

This is a discussion on Just bought 1st bugeye lots of mods but boggs down within the New Member Hangout forums, part of the Community - Meet other Enthusiasts category; I just bought a 02 wrx with an si engine installed... It has a ton of mods already on it ...

  1. #1
    Registered User
    Join Date
    Nov 2010
    Posts
    14

    Just bought 1st bugeye lots of mods but boggs down

    I just bought a 02 wrx with an si engine installed... It has a ton of mods already on it as well.. I have been reading everyones posts and seems i am checking them off one at a time.. Here is what I know.. Has new complete exhaust, new clutch, new engine, light weight flywheel, kinetic 16g turbo w evo III wheel, walbro fuel pump, and has been flashed who knows how many times with cmplete cobb tuning access port.. I think thats about it.. well i bought it for a pretty low price because it boggs down in 1st and 2nd after that it will get going pretty good but the idle is bad high then drops down low.. and NO power at all in 1st and 2nd sputters and boggs.. SO im taking to mechanic to see what he can come up with any ideas??? This is my first vehicle of this sort.. IM A COMPLETE NEWBIE!! My other cars are 03 G35 Sedan then a 07 Escalade esv so any advice i will sure appreciate .. I am wanting to learn and understand this side!! Sorry for the ramble/!!

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Moderator T0rque's Avatar
    Join Date
    Dec 2004
    Location
    Medford, Oregon
    Posts
    25,518
    I Support ClubWRX
    Talking to a mechanic really won't give you anything.. You need to take it to a specialist who deals in aftermarket parts, accessories and dyno tunes for subarus. A google search should give you a shop in your area


    Lead Wrench @ WTF Tuning, LLC

  4. #3

    Princess Moderator

    03WRX_YELLOW's Avatar
    Join Date
    May 2004
    Location
    Gresham, Oregon
    Posts
    14,843
    I Support ClubWRX
    Quote Originally Posted by got2blast View Post
    I just bought a 02 wrx with an si engine installed... It has a ton of mods already on it as well.. I have been reading everyones posts and seems i am checking them off one at a time.. Here is what I know.. Has new complete exhaust, new clutch, new engine, light weight flywheel, kinetic 16g turbo w evo III wheel, walbro fuel pump, and has been flashed who knows how many times with cmplete cobb tuning access port.. I think thats about it.. well i bought it for a pretty low price because it boggs down in 1st and 2nd after that it will get going pretty good but the idle is bad high then drops down low.. and NO power at all in 1st and 2nd sputters and boggs.. SO im taking to mechanic to see what he can come up with any ideas??? This is my first vehicle of this sort.. IM A COMPLETE NEWBIE!! My other cars are 03 G35 Sedan then a 07 Escalade esv so any advice i will sure appreciate .. I am wanting to learn and understand this side!! Sorry for the ramble/!!
    Well, if the car turns out fine mechanical then find a tuner in your area. Like Bo said take it to a aftermarket shop. People may have taken things of car and put on different parts which can change the out come of the tune. I would never buy a heavily modded car without talking to the place/shop that built and tuned it. Hope everything is okay with the car. Good luck!

    Welcome to the forum!
    Last edited by 03WRX_YELLOW; 11-08-2010 at 08:29 PM.
    Jennifer - "Consigliere" for the Bugeye Mafia
    ScoobyDMCtt - Blobeye Syndicate #007
    04 STi ECU - with Protune - FSTi Garrett GT40 -- 422whp-more to come... 12.86 @ 105

    BoBBy TuNED@ preracing.com --- DIFFERENT STROKES

  5. #4
    Banned
    Join Date
    Dec 2003
    Location
    Dallas, TX / Sterling, VA
    Posts
    6,629
    I Support ClubWRX
    ^ I'd never buy a car without knowing every single mod that that's in.

  6. #5
    Registered User
    Join Date
    Nov 2010
    Posts
    14
    Thanks guys for the advice.. The mechanic is a pro on turbos and high performance cars.. There is an awsome tune shop about 2 hours away from me in the urbs of Chicago.. I understand why you guys say you wouldnt buy a modded car , however I bought this for a steal.. It runs with all the new things on it i paid $2500.. The person i bought it from was just in need of $$$ and took that offer after needing to start paying some loans off..
    Thanks for the welcome guys and i will keep everyone posted!!

  7. #6
    zax
    zax is offline
    \_(ツ)_/ zax's Avatar
    Join Date
    Nov 2008
    Location
    Neverland Ranch, Maryland
    Posts
    12,866
    I Support ClubWRX I Support ClubWRX
    Quote Originally Posted by brfatal View Post
    ^ I'd never buy a car without knowing every single mod that that's in.
    +1... we seem to be getting a lot of these "I bought my heavily-modified car and it doesn't work, what's wrong with it?" threads lately?
    2015 CWP WRX STi ... But how did I get roped back into an EJ motor?!
    Zax's utterly unimaginably stock 2015 STi build thread
    Zax's Shaggin' Wagon Build Thread Now tuned for 99% pure Unicorn Jizz!

    Zach | Moderator -- Mid-Atlantic States, Tech & Modifying & General Repairs
    Rollin' with the Bugeye Mafia #302 | N.E.R.D. Subject Zero
    Facebook me here

    Your Mid-A local board: http://www.clubwrx.net/forums/mid-atlantic-states/

  8. #7
    Registered User dumpster's Avatar
    Join Date
    Nov 2010
    Location
    zion, ILLstate
    Posts
    43
    hope it works out for you... i was looking at a white one on cl that had a sti motor but i dont think its the same one.
    all killer ..... no filler

  9. #8
    Registered User
    Join Date
    Nov 2010
    Posts
    14
    no this is blue. it never had a chance to be posted for sale.. he mentioned one day ill fix it and then sell it .. so i just made an offer the next day as is and bam here it is... again i bought it knowing it had problems so its not as if im in shock of it.. anyone ever hear of sound performance?

  10. #9
    Registered User dumpster's Avatar
    Join Date
    Nov 2010
    Location
    zion, ILLstate
    Posts
    43
    all i have ever seen from sp back in the day was supras
    all killer ..... no filler

  11. #10
    Registered User
    Join Date
    Nov 2010
    Posts
    14
    So far the car was miswired, all the power is back and now an idle problem seems to be traced to the tgv.. So tomorrow hopefully will conclude. Does this (tgv) mess with the idle???

  12. #11
    zax
    zax is offline
    \_(ツ)_/ zax's Avatar
    Join Date
    Nov 2008
    Location
    Neverland Ranch, Maryland
    Posts
    12,866
    I Support ClubWRX I Support ClubWRX
    Quote Originally Posted by got2blast View Post
    So far the car was miswired, all the power is back and now an idle problem seems to be traced to the tgv.. So tomorrow hopefully will conclude. Does this (tgv) mess with the idle???
    TGV - Tumble Generator Valve
    http://www.drive.subaru.com/Win03_Manifold.htm

    I suppose the TGVs opening and closing could cause a "rough idle"
    2015 CWP WRX STi ... But how did I get roped back into an EJ motor?!
    Zax's utterly unimaginably stock 2015 STi build thread
    Zax's Shaggin' Wagon Build Thread Now tuned for 99% pure Unicorn Jizz!

    Zach | Moderator -- Mid-Atlantic States, Tech & Modifying & General Repairs
    Rollin' with the Bugeye Mafia #302 | N.E.R.D. Subject Zero
    Facebook me here

    Your Mid-A local board: http://www.clubwrx.net/forums/mid-atlantic-states/

  13. #12
    The Default One SeattleJeremy's Avatar
    Join Date
    Jul 2004
    Location
    Seattle, WA
    Posts
    4,488
    Quote Originally Posted by zax View Post
    TGV - Tumble Generator Valve
    http://www.drive.subaru.com/Win03_Manifold.htm

    I suppose the TGVs opening and closing could cause a "rough idle"
    Quote Originally Posted by got2blast View Post
    So far the car was miswired, all the power is back and now an idle problem seems to be traced to the tgv.. So tomorrow hopefully will conclude. Does this (tgv) mess with the idle???
    Yes. If the TGV's have been deleted then the idle may be a little rough, especially when it's cold.
    http://forums.nasioc.org/forums/show....php?t=1665615

  14. #13
    Registered User Micah's Avatar
    Join Date
    Oct 2005
    Location
    Ocean Grove, NJ
    Posts
    4,142
    My car had zero change in idle from before and after TGV delete.

    Starts up and runs in the cold too. Knock on wood.
    Torch Red 2002 Chevrolet Corvette Z06 46k mi.
    Black 2002 Subaru Impreza WRX 6-speed 94k mi. my mod list
    10/08/2006 - 14.089@103.01 (5-speed with well worn clutch, no launch)
    "Six stars gleaming, five speeds breaking, four tires chirping, three differentials working, two liters screaming, one turbo boosting... it's what makes a Subaru all-wheel-drive, all we'll drive."
    for Bugeye owners my BOV thread Service Manuals

  15. #14
    Registered User
    Join Date
    Nov 2010
    Posts
    14
    thanks alot!! he said it stumbles off the line then is all good so.... i am just having him finish it up then take to have it completly tuned from there!!

  16. #15
    Registered User
    Join Date
    Nov 2010
    Posts
    14
    Picked up "the project" and it has about 70% power idles good then will kick down almost die and lights go dim then kicks back up.. still has a sputter when i try to get on it , almost like the fuel ratio is off.. So taking it to get tuned and keeping fingers crossed taht will fix it!!!

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •