blown motor help
Results 1 to 7 of 7

This is a discussion on blown motor help within the New Member Hangout forums, part of the Community - Meet other Enthusiasts category; i have an 05 wrx with an auto trans. i blew the crank shaft bearing. any idea how or why ...

  1. #1
    Registered User
    Join Date
    Sep 2010
    Posts
    3

    blown motor help

    i have an 05 wrx with an auto trans. i blew the crank shaft bearing. any idea how or why this would happen? what can i do so i dont have to buy a motor again? thanks for the help.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    21,902
    I Support ClubWRX
    Is this a car you've owned since new and not modified in any way? Was there oil in the car?
    WRX Info Links, Courtesy TheJ
    The world breaks everyone and afterward many are strong in the broken places. Ernest Hemingway
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  4. #3
    Registered User
    Join Date
    Sep 2010
    Posts
    3
    only had the car for 3 months. i put a k&n cold air, lowering springs and new shocks on it. i had the oil change to royal purple 2 weeks before it happend.

  5. #4
    Registered User timb's Avatar
    Join Date
    Feb 2009
    Location
    Sebring Fl
    Posts
    175
    You might have over revved, but that should not have happened because you have a limiter. You could have done it if you missed a gear while down shifting say from 5 and you hit second, there is no limiter from stopping you from over revving besides locking the tires up. I am not saying you did this but it is a possibility.
    STIzzy!

  6. #5
    Registered User timb's Avatar
    Join Date
    Feb 2009
    Location
    Sebring Fl
    Posts
    175
    Well never mind. I thought it was a manny.
    STIzzy!

  7. #6
    Registered User mexicanzero's Avatar
    Join Date
    Oct 2009
    Location
    Ottawa Ontario Canada
    Posts
    262
    Quote Originally Posted by 05 bum subby View Post
    only had the car for 3 months. i put a k&n cold air, lowering springs and new shocks on it. i had the oil change to royal purple 2 weeks before it happend.
    if you've only owned the car for 3 months its very possible that the previous owner drove the crap out of it/abused it and/or drove it with little or no oil at some point

    -Alex
    LIVE LOUD, ROCK HARD!!@

    2003 WRX wagon 16g + 6 speed

  8. #7
    Sammich Makin' Pwincess wrxtreme06's Avatar
    Join Date
    May 2007
    Location
    orlando flawduh
    Posts
    12,511
    I Support ClubWRX
    hmm. i wonder if it has to do w/ the royal purple. there are several threads about it being bad for subarus. i dont really recall why exactly but just do a quick search & you'll probably find the threads.

    desiree
    your friendly, neighborhood subaru girl
    abbigale : 06 impreza wrx tr: cobb stage II
    hawkeye alliance #11:11//
    wingl3ss @ll!ance #17 // lvl 80 N.E.R.D.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •