New to the suby scene but not to cars
Results 1 to 11 of 11

This is a discussion on New to the suby scene but not to cars within the New Member Hangout forums, part of the Community - Meet other Enthusiasts category; I own two 86 corolla hatches, and just got a 02 wrx imprezza for a low low of 3.5.k but ...

  1. #1
    Registered User
    Join Date
    May 2010
    Posts
    7

    New to the suby scene but not to cars

    I own two 86 corolla hatches, and just got a 02 wrx imprezza for a low low of 3.5.k but its auto

    I just did an oil change today with 5w30 synthetic, and want to do a tune up. But I cnt find where the spark plugs are -___-
    Ive been looking left and right top and bottle.

    Also theres smoke coming out of the left side of the engine bay from under the turbo.

    Please help and Im proud to be a owner of a scooby

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    The Default One SeattleJeremy's Avatar
    Join Date
    Jul 2004
    Location
    Seattle, WA
    Posts
    4,488
    Welcome to ClubWRX!
    Check out this thread on how to replace the spark plugs.
    http://www.scoobymods.com/spark-plug...4.html?t=12294

    Edit: Here's a better thread http://www.scoobymods.com/spark-plug...96.html?t=1596

    What color is the smoke? Is there any fluids dripping off the turbo? The turbo might have a blown seal. If it does then you'll need to have it rebuild, or replaced.
    Last edited by SeattleJeremy; 05-14-2010 at 04:35 PM.

  4. #3
    Registered User
    Join Date
    May 2010
    Posts
    7
    No the smoke seems like its coming from the left head? Its around the turbo but not coming from it, its coming from somewhere under the turbo but not directly. Smoke is white, and smells like oil.

    And thanks for the links :]

  5. #4
    The Default One SeattleJeremy's Avatar
    Join Date
    Jul 2004
    Location
    Seattle, WA
    Posts
    4,488
    Time for a head gasket then

  6. #5
    Registered User
    Join Date
    May 2010
    Posts
    7
    ****. The dude that sold it to me said i needed a new valve cover gasket. Can this be cause the smoke?

  7. #6
    The Default One SeattleJeremy's Avatar
    Join Date
    Jul 2004
    Location
    Seattle, WA
    Posts
    4,488
    When you changed the oil was there water in it? Have you checked the condition of the antifreeze? Is there oil in it?

    When the engine is off does it leak oil?

  8. #7
    Registered User
    Join Date
    May 2010
    Posts
    7
    No oil leak was visible. No water in the oil. And havent done a colant flush yet.

  9. #8

  10. #9
    Registered User
    Join Date
    May 2010
    Posts
    7
    Not yet, The smoke is starting to worrry me so ima take it in to the subby dealers monday, when i get it back is when ill change the plugs. Theres no misfire or unresponsive throttle so the plugs can wait.

    could it be that i switch to a oil with less viscosity?

  11. #10
    The Default One SeattleJeremy's Avatar
    Join Date
    Jul 2004
    Location
    Seattle, WA
    Posts
    4,488
    Quote Originally Posted by Hadou-kin View Post
    could it be that i switch to a oil with less viscosity?
    Changing the oil or type of oil is not going to cause this symptom.

  12. #11
    Registered User
    Join Date
    May 2010
    Posts
    7
    true... -___- well i guess ill see monday

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •