Noise over bumps, need advice please.
+ Reply to Thread
Results 1 to 6 of 6

This is a discussion on Noise over bumps, need advice please. within the New Member Hangout forums, part of the Community - Meet other Enthusiasts category; Hi everybody, i'we been reading all posts, searched google, but found almost "0". Car 2003 WRX , 136*** miles, no ...

  1. #1
    Registered User volodyalysak's Avatar
    Join Date
    Jun 2009
    Location
    Colorado
    Posts
    149
    I Support ClubWRX

    Unhappy Noise over bumps, need advice please.

    Hi everybody, i'we been reading all posts, searched google, but found almost "0".


    Car 2003 WRX , 136*** miles, no mods to engine, no mods to exaust etc.



    Only upgrade is:

    4 tokico d-spec adjustable shocks struts i belive on stock springs with stock top mounts.

    I got my car 6 month ago, all was fine and tight, after my trip to San Francisco from Colorado my rear driver shock quit, i found 2 used shocks to put in the back of my car for 50$, while i send my bad shock to be replaced under warranty. It happened in September, and i got my new shock in February, so my friend/mechanic took out old ones and put new ones back in.

    All top bolt tight and springs installed correctly.

    My problem is:

    Well i have this awful noise from the back especialy when going over cracks in the road, potholes, even if it's 0.5 -1 inch deep. Sound like something loose, and metal binds to the metal, when under car, can't find any loose parts, don't know what bushings should look like, but seems to me they ok. And the noise is the worst when i go over bump and turn, it feels like whole back going to fall apart, it like you hit the metal covered with plastic.

    The same sound comes from front but quiter with the same symphtoms.

    It's quiter when it raining outside .......

    Help me to identify, or if anyone lives in Denver and willing to help me to identify the problem before i waste my money, i was thinking to replace all bushings , but have no idea if it going to help.


    Any reply and advice will be hightly appreciated from you.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User T.J.'s Avatar
    Join Date
    Oct 2002
    Location
    on a boat...
    Posts
    821
    The common problems to look for are worn stabilizer bushings and end links.

    I know you have already done this but all I can suggest is to get under the back of your car and push/pull the ends of your stabilizer bar and see if there is play in the bushings or end link.

    I have one of each to replace on my Impreza and the wife's Forester right now.

    Good luck, T.J.
    200,000 mile club.

    Old Irish adage: "Do not resent growing old. Many are denied the privilege."

  4. #3
    Registered User volodyalysak's Avatar
    Join Date
    Jun 2009
    Location
    Colorado
    Posts
    149
    I Support ClubWRX
    How hard would be to replace them ? Which one would you suggest ? Any DIY or tips ?
    Thanks

  5. #4
    Registered User T.J.'s Avatar
    Join Date
    Oct 2002
    Location
    on a boat...
    Posts
    821
    I would suggest replacing which ever one rattles when you shake it.

    Pretty easy to replace either. It will be self explanatory when you look under the car. If not, this thread should cover it: Rear Sway Bar/EndLinks Install

    Hell, while you're at it you might as well just replace the rear bar and end links for better handling. The new bar will come w/ new bushings.
    200,000 mile club.

    Old Irish adage: "Do not resent growing old. Many are denied the privilege."

  6. #5
    Registered User volodyalysak's Avatar
    Join Date
    Jun 2009
    Location
    Colorado
    Posts
    149
    I Support ClubWRX
    The problem is ,when I try to find a rattle it's all solid ,as soon as. I hit any bump/crack it rattles ,binds.is any way to find out what exactly need to be replaced? I don't have enough money to replace all bushing endlinks and sway bar.thanks again

  7. #6
    Registered User dehnem's Avatar
    Join Date
    Mar 2006
    Location
    Wisconsin
    Posts
    344
    did you replace your swaybar as upgrade? or was it out of necessity?
    96 Mustang: Shorty Headers, X-pipe, Electronic cut out, Air silencer Delete, K&N air filter, really sticky tires
    (14.32 @ 96.7mph)

    02 bugeye: exedy oem clutch, kybAGX struts, momo short-throw shifter, steel braided brake lines, stoptech rotors and stock rims (the 17inch wheel just weighed too much), 14.232 @ 94.75mph

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •