Got more pics - Page 2
+ Reply to Thread
Page 2 of 2 FirstFirst 12
Results 16 to 20 of 20

This is a discussion on Got more pics within the New Member Hangout forums, part of the Community - Meet other Enthusiasts category; sorry for the crappy picture and this is off an 03 but if you follow the rubber connector straight up ...

  1. #16
    Supporting Member yamaha_rider619's Avatar
    Join Date
    Jul 2009
    Location
    colorado is home, Kansas is the temporary home
    Posts
    1,719
    I Support ClubWRX
    sorry for the crappy picture and this is off an 03 but if you follow the rubber connector straight up from from the cai, its that little tiny thing where the wire plugs in on top.

    Josh
    2003 Subaru Wrx Vf39'd
    Bugeye mafia #300

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #17
    Baconator azWRX06's Avatar
    Join Date
    Apr 2006
    Location
    Gilbert, Arizona, United States
    Posts
    1,466
    I Support ClubWRX
    Thanks Yamaha!

    Yeah, that's the spot. Some people will go with the manual boost controler (a valve with a knob turned by hand) and that never usually gets put back the way it was.
    -AJ | Hawk-Eye Alliance #55 | Stink-Eye Mob #1
    NASIOC - Narcissistic, Arrogant, Self Involved, Oligarchy of Cryptorchidisms

    2011 Chevy Camaro SS RS Package & 2011 Honda Pilot
    Used to have: Protune Stage 2 2010 Subaru WRX
    Used to have: Stage 4 2006 Subaru WRX

    Add me to Facebook

  4. #18
    Registered User
    Join Date
    Jan 2010
    Posts
    1
    this the picture of 02 WRX. Hope this will give you help.

  5. #19
    Supporting Member yamaha_rider619's Avatar
    Join Date
    Jul 2009
    Location
    colorado is home, Kansas is the temporary home
    Posts
    1,719
    I Support ClubWRX
    link, ever thought about getting a intake heat shield?
    Josh
    2003 Subaru Wrx Vf39'd
    Bugeye mafia #300

  6. #20
    Registered User
    Join Date
    Oct 2009
    Posts
    24
    Thanks guys. Much help. I know intercoolers isn't what this thread was talking about, but I got a quick ?. When you install a front mount, do you always have to relocate the radiator overflow tank?, and if so, is that a hard thing to do??? or do you have to buy a new one all together. much appreciated ya'll.

+ Reply to Thread
Page 2 of 2 FirstFirst 12

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •