First Subie bought yesterday
Results 1 to 9 of 9

This is a discussion on First Subie bought yesterday within the New Member Hangout forums, part of the Community - Meet other Enthusiasts category; Hey everyone,new to the site,althought ive been looking around on it for weeks now scoping all the info. Just picked ...

  1. #1
    Registered User jsnm's Avatar
    Join Date
    Oct 2009
    Location
    DE
    Posts
    71

    Thumbs up First Subie bought yesterday

    Hey everyone,new to the site,althought ive been looking around on it for weeks now scoping all the info.

    Just picked up an 06 White WRX yesterday,traded my G35 for it.Had many cars(acura,bmw,toyota,etc) and never enjoyed a car as much as i already have this one!
    I dont know what i waited so long for to actually pull the trigger and get one, guess it was the boredom of the infiniti.

    The only thing im a little worried about is the car has 65k miles on it,and it seems to run fine when under a load,but sitting at idle sometimes i get a vibration.
    Almost seems like a misfire or something going on under there,i just hope the internals are sound.

    Also,seems a little sluggish when taking off till about 3700 rpms or so then it seems to smooth out and get into boost a little better.

    Anything particular i should look for wrong under the hood,or does it just need a good tune up??

    Oh,the car is 100% stock as well.

    Thanks,
    Jesse

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Moderator   Sasquatch's Avatar
    Join Date
    Apr 2004
    Location
    Southeastern PA
    Posts
    31,079
    I Support ClubWRX
    Greetings and welcome to the Club Jesse!

    Quote Originally Posted by jsnm View Post
    Just picked up an 06 White WRX yesterday,traded my G35 for it.
    One of our admins had a G35.

    Quote Originally Posted by jsnm View Post
    The only thing im a little worried about is the car has 65k miles on it,and it seems to run fine when under a load,but sitting at idle sometimes i get a vibration.
    The WRX engine is nowhere near as smooth as the G35 V6 at idle - what you feel is likely normal.

    Quote Originally Posted by jsnm View Post
    Also,seems a little sluggish when taking off till about 3700 rpms or so then it seems to smooth out and get into boost a little better.
    Welcome to the world of turbo lag. Again, compared to the G35 something may seem wrong. This is likely not the case. The perceived power curve on the G35 is far smoother and more linear.
    Moderator for: Aftermarket Vendor & Installer Review / Detailing Forum / Engine Modifications / Exterior & Appearance
    New Member Hangout / Off Topic / Tri-State
    ScoobyDMC #003 Blobeye Syndicate #10
    2004 WRX Sedan PSM 5MT Tactrix Stage 2+ Blouch TD04 19T @ 21 psi
    Mods & Pics

  4. #3
    Registered User jsnm's Avatar
    Join Date
    Oct 2009
    Location
    DE
    Posts
    71
    Hey thanks for the response,i figured it was probably just a normal vibration thing.
    I guess i should have better explained the situation when accelerating a little better.
    It seems to break up a little bit here and there when accelerating.I guess thats what im asking and not the lag part.

    Should i just change out the plugs and do a mild tune up before anything else?

  5. #4
    Administrator RayfieldsWRX's Avatar
    Join Date
    Oct 2002
    Location
    The Old Folks Home
    Posts
    46,907
    I Support ClubWRX
    Welcome to ClubWRX. I'm the afore-mentioned admin that once owned a black G35c.

    Actually..I owned a somewhat modded WRX sedan, sold it, and bought the G new because I thought I wanted something more refined. I owned another WRX within 6 months.

    Nothing wrong with the G35, of course, just not the right fit for a driver that wants some excitement when he presses the pedal. Once you're confident that your WRX is in good tune, you might consider some basic mods; these cars are transformed with a minimal investment.
    --Ray
    Grandfather of the Bugeye Mafia
    2013 Subaru BRZ Limited
    2002 Subaru WRX Bugeyebrid Wagon

  6. #5
    Moderator   Sasquatch's Avatar
    Join Date
    Apr 2004
    Location
    Southeastern PA
    Posts
    31,079
    I Support ClubWRX
    Quote Originally Posted by jsnm View Post
    Hey thanks for the response,i figured it was probably just a normal vibration thing.
    I guess i should have better explained the situation when accelerating a little better.
    It seems to break up a little bit here and there when accelerating.I guess thats what im asking and not the lag part.

    Should i just change out the plugs and do a mild tune up before anything else?
    Did you get any kind of service history? Are you certain the car was always 100% stock? Reverting back to stock like condition may have left something out of adjustment.

    At 65k I would check the plugs and air filter. I'd bet the MAF sensor needs cleaning.
    Moderator for: Aftermarket Vendor & Installer Review / Detailing Forum / Engine Modifications / Exterior & Appearance
    New Member Hangout / Off Topic / Tri-State
    ScoobyDMC #003 Blobeye Syndicate #10
    2004 WRX Sedan PSM 5MT Tactrix Stage 2+ Blouch TD04 19T @ 21 psi
    Mods & Pics

  7. #6

    Flirty User That's Younger Than the Chunks of Corn in Brian's Crap

    WRXie's Avatar
    Join Date
    Mar 2009
    Location
    Down South
    Posts
    3,044
    Welcome to the club!! Got any pics of the car? There aren't many white ones.
    2002 WRX Yellow Blaze


    Bugeye Mafia #216

    High Mileage Club

  8. #7
    Registered User jsnm's Avatar
    Join Date
    Oct 2009
    Location
    DE
    Posts
    71
    I ran a carfax on it,1 original owner,all the service was done at the dealer,thats about all i can see.
    When i look at all the clamps,hoses and stuff it all seems like it hasnt been touched.Seems like you can tell sometimes when some things look clean,others are dirty,markings,etc.
    Thats just my prediction,who knows though.
    Thats one thing i did do was pull out the maf and cleaned the hell out of it with some crc cleaner,it was absolutely filthy.
    The air filter looked horrible too,needs replaced.

    Id also like to change the oil,trans fluid,and diff fluids for peace of mind.

  9. #8
    Moderator   Sasquatch's Avatar
    Join Date
    Apr 2004
    Location
    Southeastern PA
    Posts
    31,079
    I Support ClubWRX
    Read on: How to Buy a Used WRX or STI

    Quote Originally Posted by jsnm View Post
    Thats one thing i did do was pull out the maf and cleaned the hell out of it with some crc cleaner,it was absolutely filthy. The air filter looked horrible too,needs replaced.

    Id also like to change the oil,trans fluid,and diff fluids for peace of mind.
    If the simple stuff (MAF, air filter) was not taken care of I would do all of the fluids as well.
    Moderator for: Aftermarket Vendor & Installer Review / Detailing Forum / Engine Modifications / Exterior & Appearance
    New Member Hangout / Off Topic / Tri-State
    ScoobyDMC #003 Blobeye Syndicate #10
    2004 WRX Sedan PSM 5MT Tactrix Stage 2+ Blouch TD04 19T @ 21 psi
    Mods & Pics

  10. #9
    Registered User jsnm's Avatar
    Join Date
    Oct 2009
    Location
    DE
    Posts
    71
    Yea,ill take care of it all this weekend,do you guys think i have anything to worry about with the amount of mileage on the motor?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •