fuel problems...help plz
+ Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 21

This is a discussion on fuel problems...help plz within the New Member Hangout forums, part of the Community - Meet other Enthusiasts category; my car wont start, i check the fuel pump relay, it works, fuel regulator works, change fuel pump. but my ...

  1. #1
    Registered User
    Join Date
    Jun 2009
    Posts
    12

    Wink fuel problems...help plz

    my car wont start, i check the fuel pump relay, it works, fuel regulator works, change fuel pump. but my car still wont start, fuel its not been deliver to the fuel filter, what could be wrong? yes a follow every step n recomendations.

    omar

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User vttk_mig69's Avatar
    Join Date
    Jan 2008
    Location
    Sheboygan, WI
    Posts
    527
    did you check the spark plugs and or coil packs and other electrical ignition components?

  4. #3
    Registered User
    Join Date
    Jun 2009
    Posts
    12
    Quote Originally Posted by vttk_mig69 View Post
    did you check the spark plugs and or coil packs and other electrical ignition components?
    yeah everything looks fine, i just dont know what else to do?

  5. #4
    Registered User CJ05's Avatar
    Join Date
    Apr 2008
    Location
    North Juarez Mexico (aka El Paso TX)
    Posts
    1,178
    Did you plug back in every connection that you disconnected for the install? Something left unplugged somewhere perhaps?
    Bugeye Mafia #231 - 2002 WRB - sold Dec 31, 2009
    -Stink-Eye Mob- #173 - 2008 SWP - Returned to TD04 Stage 2 in Jan 2012
    Frmr Blobeye Syndicate #173 - 2005 CGM -sold Sept 15, 2008. I miss my STi
    Proud owner of 99 RS coupe with EJ205 engine and tranny swap.

  6. #5
    Registered User
    Join Date
    Jun 2009
    Posts
    12
    Quote Originally Posted by CJ05 View Post
    Did you plug back in every connection that you disconnected for the install? Something left unplugged somewhere perhaps?
    yeah i been back step by step everything its plugged in, everything is set.

  7. #6
    Registered User
    Join Date
    Jun 2009
    Posts
    12
    anyone out there...plz help

  8. #7
    Registered User wrx0131's Avatar
    Join Date
    Jul 2007
    Location
    Yonkers, NY
    Posts
    1,385
    how do you know its a fuel problem?
    Bugeye Mafia #213
    Kevin
    2002 Midnight Black Pearl WRX (Traded In!)

    2012 Ice Silver Metallic STi Sedan

  9. #8
    Registered User
    Join Date
    Jun 2009
    Posts
    12
    fuel is not been deliver to the fuel filter.

    Quote Originally Posted by wrx0131 View Post
    how do you know its a fuel problem?

  10. #9
    Registered User BringDownTheSky's Avatar
    Join Date
    Aug 2009
    Location
    Brandon, Fl
    Posts
    176
    Quote Originally Posted by Maldito Duende View Post
    fuel is not been deliver to the fuel filter.
    how do you know that? is it turning over and dying? or is it not starting at all?

  11. #10
    Registered User
    Join Date
    Jun 2009
    Posts
    12
    it doesnt start at all, fuel filter its new, fuel pump its new, relay its new, regulator its fine, car crnks but wont start

    Quote Originally Posted by BringDownTheSky View Post
    how do you know that? is it turning over and dying? or is it not starting at all?

  12. #11
    Registered User JUSTINSNUTSWINGER's Avatar
    Join Date
    Jul 2008
    Location
    San Antonio
    Posts
    1,923
    What did you do right before all this started happening ?
    N-swinger

    2000 Escort

    Maintenance schedule and poke in the eyes:
    http://www.clubwrx.net/forums/genera...nce-guide.html

  13. #12
    Registered User
    Join Date
    Jun 2009
    Posts
    12
    its been parked for like 2 months, i use it once in a while, but i got the emission test paper in the mail, but i need the the 02 sensor, i replace that, but i was suspended so i had my dad to drive it to the emission test facility, but he doesnt really know how to drive manual, so he was driving like a roockie, so 5 blocks down from my house the car die n theres where all started. i used the starting fluid n it almost started, i change fuel filter on the spot, but still wouldnt start so i had to tow it back home.

    Quote Originally Posted by pzr2874 View Post
    What did you do right before all this started happening ?

  14. #13
    Registered User wrx0131's Avatar
    Join Date
    Jul 2007
    Location
    Yonkers, NY
    Posts
    1,385
    Quote Originally Posted by Maldito Duende View Post
    its been parked for like 2 months, i use it once in a while, but i got the emission test paper in the mail, but i need the the 02 sensor, i replace that, but i was suspended so i had my dad to drive it to the emission test facility, but he doesnt really know how to drive manual, so he was driving like a roockie, so 5 blocks down from my house the car die n theres where all started. i used the starting fluid n it almost started, i change fuel filter on the spot, but still wouldnt start so i had to tow it back home.
    are you sure it's not your battery or alternator?

    fuel injectors?
    Bugeye Mafia #213
    Kevin
    2002 Midnight Black Pearl WRX (Traded In!)

    2012 Ice Silver Metallic STi Sedan

  15. #14
    Registered User JUSTINSNUTSWINGER's Avatar
    Join Date
    Jul 2008
    Location
    San Antonio
    Posts
    1,923
    I'm thinking it sat too long. clogged injectors ? All of them at one time ? I doubt it. Changed the fuel filter on the spot ? Did you chk the fuel pump ? And did you chk the "sock" on the fuel pump ?
    N-swinger

    2000 Escort

    Maintenance schedule and poke in the eyes:
    http://www.clubwrx.net/forums/genera...nce-guide.html

  16. #15
    Registered User
    Join Date
    Jun 2009
    Posts
    12
    it can be the injector, but why gasiline doesnt get to the fuel filter? change fuel filter on the spot, i meant i change it where the car died before i tow it back home, i replaced the fuel pump, theres power on the fuel pump, whats the SHOCK on the fuel pump?

    Quote Originally Posted by pzr2874 View Post
    I'm thinking it sat too long. clogged injectors ? All of them at one time ? I doubt it. Changed the fuel filter on the spot ? Did you chk the fuel pump ? And did you chk the "sock" on the fuel pump ?

+ Reply to Thread
Page 1 of 2 12 LastLast

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •