Hello, I'm Otto the 2002 WRX wagon.
+ Reply to Thread
Results 1 to 4 of 4

This is a discussion on Hello, I'm Otto the 2002 WRX wagon. within the New Member Hangout forums, part of the Community - Meet other Enthusiasts category; Hey, my name is Erik, my wagon and I hail from Vancouver, WA. We've shared many memories, activities, fun times, ...

  1. #1
    Registered User
    Join Date
    Dec 2008
    Location
    Vancouver, WA
    Posts
    4

    Hello, I'm Otto the 2002 WRX wagon.

    Hey, my name is Erik, my wagon and I hail from Vancouver, WA. We've shared many memories, activities, fun times, and unfun times since 44K miles in June 04 when I bought "Otto". A friend bought Otto new and left him stock except K&N drop in air filter. That friend moved overseas, and I was in the market for a WRX wagon. Deal was struck, and its been great ever since. Otto and I like to RallyX/AutoX/drag race occasionally, commuting, and toting just about everything under the moon in either the back of the car, on the roof, or on the little trailer behind the car.

    Couple required upgrades after kissing a curb: 04 STI rack and pinion on Whiteline bushings, Kartboy endlinks F+R, and Cusco sways F+R. Some other goodies I've picked up along the way: KYG AGX/ProKits, catless exhaust, JDM STI top mount and scoop, Morrette headlights (these need an upgrade of some sort-they dont light up the road like they used to), some Hella horns and a Pioneer Navi head unit. I'm sure theres more, but thats enough for now.

    At 104K miles of fun (and abuse), the stock clutch started slipping. PRE in Gresham (Portland, OR) turned out to be very helpful in setting me up with an Exedy Stage 1 organic replacement kit. I've been pretty good with wrenches my whole life, so I jumped in and got to swapping out the old for the new. Now I'm only about 70 miles in on the break in, and have encountered my first problem. My boost levels have always been 15psi peak, then slowly trickled down to 12ish. Without touching anything boost related other than removing and reinstalling the IC, boost spikes to 20+ pretty much instantly then immediatly drops to less than 5 and the car falls flat on its face. So maybe the DP is hanging up the WGA? All the vacuum lines to the boost controller seem intact (this is what I found out after swapping to the JDM STI TMIC ages ago and tearing the line under the passenger/front corner of the IC). No strange noises anywhere, just boost levels all wierd. So I've been babying the car like crazy to keep things safe. Any ideas?

    Thanks,

    and here are some shots of Otto and I having fun:









    Erik

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User gprwrx's Avatar
    Join Date
    Apr 2008
    Location
    Stroudsburg, Pennsylvania
    Posts
    805
    Looks like fun!
    02PSMWRX VF39'd STI Killer
    Wingl3ssAlli@nce#27

  4. #3
    Registered User
    Join Date
    Jan 2009
    Posts
    4
    looks like a blast dude!

  5. #4
    Administrator TheJ's Avatar
    Join Date
    Jul 2002
    Location
    Bro do you even live in the Dirty South
    Posts
    18,123
    I Support ClubWRX
    Welcome to the club.
    She looks awesome!
    Sounds like something was missed when working thew IC. I would definitely go back over that.
    -The J
    New Members, CLICK & BOOKMARK these links:


    "Driving most supercars is like trying to manhandle a cow up a back staircase. . . This is like smearing honey into Keira Knightly" -JC

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •