New to forum, 60K CEL, Questions
Results 1 to 5 of 5

This is a discussion on New to forum, 60K CEL, Questions within the New Member Hangout forums, part of the Community - Meet other Enthusiasts category; 2004 STI bought new just turned 60K. Have kept totally stock. Just got a CEL (cruise flashing), only symptom is ...

  1. #1
    Registered User
    Join Date
    Aug 2008
    Posts
    2

    Wink New to forum, 60K CEL, Questions

    2004 STI bought new just turned 60K. Have kept totally stock. Just got a CEL (cruise flashing), only symptom is maybe a little recent rougher idol.
    Took it in to the dealer immediately.
    Diagonstic was #2 cylinder misfiring.
    They ruled out the plug, "must be compression or fuel delivery".
    Checked compression in #2 = LOW (holy crap).
    Checked compression in all = MARGINAL at best.
    Looked in all cylinders with scope and all "beautiful".
    Decided to do 60K tune (I did not do 30K tune) and replace the #2 fuel injector).
    Dealer says will have to go into the engine to further diagnosis.

    Car runs great, strong under acceleratoin, has never been raced or abused, religious with oil changes (Mobil 1 at every 3k) and does not burn any. In my opinion there should be no reason for significant loss of compression based on the way this car has been maintained or driven.

    Any comments would be greatly appreciated.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2

    Admin - Scooby Hooligan

    Weasel 555's Avatar
    Join Date
    Jul 2002
    Location
    UK,NY,AK,FL
    Posts
    23,121
    I Support ClubWRX
    Welcome, dunno if this will help but....


    ok i just replaced my ej2.0T block since #4 cyl was misfiring , replaced plugs still misfire ,swapped coil packs still misfire,checked cylinder compressions #4 80 , 1,2,3 all approx 135.

    my scooby techs said just buy new block , as its basically same price as taking engine out and replacing the piston /rings in cyl #4 and you still have no guarantee that the low compression will be cured. Also they noted even looking at the block/piston/sleeve #4 you wouldnt know anything was wrong.
    Anywho replaced ej2.0T block with a 2.5T block teehehehe
    ScoobyDMC #000,HawkEyeAlliance#000,Blobeye Syndicate #000, SQC-NY #009, "Dragon Slayer"
    "All We'll Drive"

    I <3 boobies: rallyarmor/keepabreast/mud flaps limited edition

  4. #3
    Registered User
    Join Date
    Aug 2008
    Posts
    2

    Thanks Weasel

    What symptoms did yours have? Anything significant or was it mainly the CEL going off?

    Yes, we have discussed options and if needed sounds like the short block is the way to go.

    I just drove it over 600 miles since the service and it seems to be running great!

    Thanks!

  5. #4

    Admin - Scooby Hooligan

    Weasel 555's Avatar
    Join Date
    Jul 2002
    Location
    UK,NY,AK,FL
    Posts
    23,121
    I Support ClubWRX
    Quote Originally Posted by Weasel 555 View Post
    ok i just replaced my ej2.0T block since #4 cyl was misfiring , replaced plugs still misfire ,swapped coil packs still misfire,checked cylinder compressions #4 80 , 1,2,3 all approx 135.
    those symptoms, car drove fine mainly coz the turbo/power will mask the Inadequacies of the lower compression cylinder.

    imho i would get another compression check see what the cylinders are putting out.
    ScoobyDMC #000,HawkEyeAlliance#000,Blobeye Syndicate #000, SQC-NY #009, "Dragon Slayer"
    "All We'll Drive"

    I <3 boobies: rallyarmor/keepabreast/mud flaps limited edition

  6. #5
    DUB
    DUB is offline
    Registered User DUB's Avatar
    Join Date
    Jul 2007
    Location
    SLT, CA
    Posts
    3,176
    So you skipped the 30k service entirely and you are boasting about how immaculately the car has been maintained?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •