Turning 7 this year
+ Reply to Thread
Results 1 to 8 of 8

This is a discussion on Turning 7 this year within the New Member Hangout forums, part of the Community - Meet other Enthusiasts category; Hi All, I have been married to my Rexxie for 6 years now, and have had very little if no ...

  1. #1
    Registered User RexDownUnda's Avatar
    Join Date
    Aug 2008
    Location
    Sydney, Australia
    Posts
    11

    Turning 7 this year

    Hi All,

    I have been married to my Rexxie for 6 years now, and have had very little if no problems with it. Now, just as she's turning 7, she's having a llittle issue with the CEL coming on and Subaru have already charged me $1500 to DIAGNOSE the problem, which was not Diagnosed in the end.

    So here I am to try and broaden my knowledge in the land of WRX~to hopefully do some self diag / repairs - and at the same time join what looks like a close knit community of WRX enthusiasts.

    Its obvious from the comradery that the WRX community are really willing to help each otha out' to amazing extents.
    As mentioned by another new user - when you purcahse a Subaru - it comes with "friends" - whether it be at the lights or just passing by - a wave is inevitable' - well it is here in Australia'

    I also gotta say - some of you have very nice setups'
    I hopefully myself will upgrade to a clean '06 Sti soon.

    See u around the site'
    _______________________
    ~Subaru 4 life~

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Administrator TheJ's Avatar
    Join Date
    Jul 2002
    Location
    Bro do you even live in the Dirty South
    Posts
    18,123
    I Support ClubWRX
    Welcome to the club!
    -The J
    New Members, CLICK & BOOKMARK these links:


    "Driving most supercars is like trying to manhandle a cow up a back staircase. . . This is like smearing honey into Keira Knightly" -JC

  4. #3
    Supporting Member mjboudreaux77's Avatar
    Join Date
    Sep 2007
    Location
    Northern Vermont
    Posts
    843
    I Support ClubWRX
    Can you give us some symptoms, or is it just a light? What did the computer say it was?
    If I don't die by Thursday, I'll be roarin Friday night - Jimmy Buffett

  5. #4

    Admin - Scooby Hooligan

    Weasel 555's Avatar
    Join Date
    Jul 2002
    Location
    UK,NY,AK,FL
    Posts
    23,158
    I Support ClubWRX
    welcome and congrats on owning a scooby for 7yrs
    ScoobyDMC #000,HawkEyeAlliance#000,Blobeye Syndicate #000, SQC-NY #009, "Dragon Slayer"
    "All We'll Drive"

    I <3 boobies: rallyarmor/keepabreast/mud flaps limited edition

  6. #5
    Registered User CentaurStream's Avatar
    Join Date
    Aug 2008
    Location
    Medfield, MA
    Posts
    27

    Whew... I thought you were going to stray...

    Quote Originally Posted by RexDownUnda View Post
    Hi All,

    I have been married to my Rexxie for 6 years now, and have had very little if no problems with it. Now, just as she's turning 7, she's having a llittle issue with the CEL coming on and Subaru have already charged me $1500 to DIAGNOSE the problem, which was not Diagnosed in the end.

    So here I am to try and broaden my knowledge in the land of WRX~to hopefully do some self diag / repairs - and at the same time join what looks like a close knit community of WRX enthusiasts.

    Its obvious from the comradery that the WRX community are really willing to help each otha out' to amazing extents.
    As mentioned by another new user - when you purcahse a Subaru - it comes with "friends" - whether it be at the lights or just passing by - a wave is inevitable' - well it is here in Australia'

    I also gotta say - some of you have very nice setups'
    I hopefully myself will upgrade to a clean '06 Sti soon.

    See u around the site'
    I thought you were going to say you got the seven year itch and were planning on straying from your subie... don't worry with your support group here, you will work this out!

  7. #6
    Registered User RexDownUnda's Avatar
    Join Date
    Aug 2008
    Location
    Sydney, Australia
    Posts
    11

    Can I post here ?

    Quote Originally Posted by mjboudreaux77 View Post
    Can you give us some symptoms, or is it just a light? What did the computer say it was?
    Hi All, wasn't sure whether I should post the symptoms / problems in this forum...

    Anyway - got Subaru to pull OBD codes, stupid thing is that I didnt get the code numbers.

    1st code was a neutral air control issue.
    2nd code was apparently a MAP sensor issue.

    I am waiting for a device I have ordered to try and pull the exact code numbers. Hopefully will arrive today. (cloned ELM-327)

    Symptoms are:

    1. Car "jumped" into what seemed like a misfire type of situation, no power?? Went like a GX !! - I also noted that the idle RPM was not constant (between 500-1500) and would sometimes fluctuate immensly when stopped at lights etc.

    I removed the IACV and have thoroughly cleaned it with WD-40,re-fitted with a new IACV gasket, and high tensile hex nuts. The thing was FILTHY !! surprised the valve could even move...

    This seems to have rectified my idle problem and also the lack of power issue. I assume the IACV was staying open even when the car was not in IDLE position...

    ***Can anyone verify this could have been the case??***

    2. When I put my foot down, will go to launch, and then cut out abruptly. I almost give myself a black eye every time it happens - from hitting the steering wheel - its that abrupt.

    It seems to happen instantly when I really give it some, if i gradually get the RPMs up, it seems to go a bit further and then cut out. Can happen anywhere in between 3-5k rpm


    Subaru advised that this could be a MAP sensor issue, as the 2nd code was indicating a MAP sensor issue.

    (after Subaru had already charged me $600 for inspecting the Coil packs, replacing my Spark plugs and more diagnostics)

    I have then asked Subaru to replaced the MAP sensor. $$$$ &*^&(*!@#

    OK, so I then was a very happy boy returning home - NOT.
    On the way home, I tried to give it some to verify that the issue was in fact the MAP sensor. I put my foot down, it launched slightly, and then cut out abruptly !!! Aarrghhhh!!

    I popped my bonnet when I got home and was digusted to find the hose clamps on the aire inlet had been left undone, a small tube had been left of a blue valve ? not sure what it was, and a cable that had a mounting bracket on it (looks like something to do with the ABS - front Drivers side near wheel arch) had come off and was dangling in the wind - bracket cable and all !

    I expect this maybe from Kia, but not from Subaru...!!
    [I would like to swear here]

    I put the car into Suabru once more, (daring i know) and they could not find another issue, although the CEL was still coming on.

    They tried to charge me another $500 for diagnostics, and I went off. I called Subaru's head office while standing in the CS department of the service centre. I refused to pay, and Head Office Ok'd me to take the car without paying. I was not going to spend $2000 to diagnose a problem. Each pop they were charging $400 - 500 !! for diagnostics...

    Anyway - as mentioned above, will hopefully receive my ELM today to pull some codes. Will update asap.

    I miss being able to put my foot down.
    _______________________
    ~Subaru 4 life~

  8. #7
    Registered User RexDownUnda's Avatar
    Join Date
    Aug 2008
    Location
    Sydney, Australia
    Posts
    11

    Don't think I could'

    Quote Originally Posted by CentaurStream View Post


    I thought you were going to say you got the seven year itch and were planning on straying from your subie... don't worry with your support group here, you will work this out!
    Gotta say, don't think I'd never drive anything else but a WRX - there is nothing that can handle and perform quite like a Rexxie.
    _______________________
    ~Subaru 4 life~

  9. #8
    Moderator   Sasquatch's Avatar
    Join Date
    Apr 2004
    Location
    Southeastern PA
    Posts
    31,262
    I Support ClubWRX
    Hello there - welcome to the club!
    Moderator for: Aftermarket Vendor & Installer Review / Detailing Forum / Engine Modifications / Exterior & Appearance
    New Member Hangout / Off Topic / Tri-State
    ScoobyDMC #003 Blobeye Syndicate #10
    2004 WRX Sedan PSM 5MT Tactrix Stage 2+ Blouch TD04 19T @ 21 psi
    Mods & Pics

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •