new sti owner... - Page 2
Page 2 of 2 FirstFirst 12
Results 16 to 21 of 21

This is a discussion on new sti owner... within the New Member Hangout forums, part of the Community - Meet other Enthusiasts category; welcome! that's one beastly sti you just bought yourself. enjoy all that power....

  1. #16
    Registered User SuBiEklD's Avatar
    Join Date
    Aug 2006
    Location
    Strict Emissions Law, California
    Posts
    473
    welcome!

    that's one beastly sti you just bought yourself. enjoy all that power.
    BLOBEYE SYNDICATE #524
    "Life isn't about the number of breaths we take, but the moments that take our breath away"

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #17
    Administrator TheJ's Avatar
    Join Date
    Jul 2002
    Location
    Bro do you even live in the Dirty South
    Posts
    17,806
    I Support ClubWRX
    Quote Originally Posted by SCTibby04 View Post
    The car dynoed today at 409awhp and 350awtq with the euc-tek. It is an absolute beast, I can;t wait to drive it....lol
    Very nice!
    -The J
    New Members, CLICK & BOOKMARK these links:


  4. #18
    Registered User SCTibby04's Avatar
    Join Date
    Dec 2004
    Posts
    15
    Quote Originally Posted by xsnapshot View Post
    when you get to drive it again, report back and tell us how it stacks up against your tiburon. Im curious....i have a feeling it'll win in the quarter.....but from a roll? Whats the gearing like on your tiburon?
    I would think with the awd launch it should win in the quarter. I was just dynoing my tiburon this past monday and ran into some problems, the car still made over 300wtq from 2700rpms to 5000 then fell off a bit. Tuning with the hydra is fun, I wonder what one would do for the STi.

    The shop that dynoed the STi said there is a crack in the exhaust manifold up-pipe flange hurting the spool time, any thoughts on that?
    Last edited by SCTibby04; 07-02-2008 at 07:34 AM.

  5. #19
    Registered User
    Join Date
    Jan 2008
    Location
    Nebraska
    Posts
    681
    ya i'd fix it right away. Thats a no good deal. Do you know if the crack is on the uppipe side or the manifold side? I guess that probably means you have aftermarket headers. Probably EL headers that come with an uppipe?

    I'd take em off and take them to a local engine/machine shop and see if they can fix/weld it for you.

    I would think Hydra done right would be absoluely AWESOME on an STi from what ive heard. Too bad its so much $

  6. #20
    Registered User SCTibby04's Avatar
    Join Date
    Dec 2004
    Posts
    15
    Yeah, I don't want to buy another hydra right now. The one I just bought for my tiburon was 2K

    The leak was just from a gasket.

  7. #21
    Registered User Az subie's Avatar
    Join Date
    Jun 2008
    Location
    Phoenix, az
    Posts
    101
    welcome to the club! Beautifal scooby btw

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •