Just a few questions about an 02 wrx
Results 1 to 5 of 5

This is a discussion on Just a few questions about an 02 wrx within the New Member Hangout forums, part of the Community - Meet other Enthusiasts category; Hello everyone, First off, I purchased a MBP 5mt 02 wrx wagon in November 05 and 3 weeks ago during ...

  1. #1
    Registered User
    Join Date
    Nov 2005
    Location
    Glen Spey NY
    Posts
    5

    Just a few questions about an 02 wrx

    Hello everyone,

    First off, I purchased a MBP 5mt 02 wrx wagon in November 05 and 3 weeks ago during a real cold night (about 5 degrees) the CEL came on and blinked for about 5 seconds and then went off. The dealer I bought it from said it was nothing to worry about. The car has a 3year/40k mile bumper to bumper warranty they threw in, so I'm not really worried but I'm curious to why it would do that. I figure from the cold it was just a malfunctioning sensor or something. On my drive home from work tonight, I stopped at my friends house who rides to work with me and when I shut my car off, the parking lights wouldn't turn off unless I disconnect the battery. I am taking my car to the dealer tomorrow to get this problem resolved and for an oil change, but I'm wondering what would cause this. I was thinking the switch that controls the lights, not the fogs. Thank you in advance for your answers in case I don't visit for a day or two.

    evil

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User
    Join Date
    Jan 2006
    Posts
    50
    DO NOT DRIVE THE CAR WITH A FLASHING CEL. I would have the car taken directly to the dealer. Was the car idling rough when the light was flashing? The reason im asking is that i read in another post that a flashing CEL means the engine is misfiring. But i can not say this for sure in your case. But a flashing CEL is definetly not....NOTHING like your dealer said. Also im not sure if your aware of the switch that is located on top of the steering column. That switch will allow the parking lamps to stay on when the car is off. Also was this car ever modded or wrecked before you bought it??

  4. #3
    Registered User wrx wagone's Avatar
    Join Date
    May 2005
    Location
    Phillytown, PA
    Posts
    10,774
    Alright, relax. If the car is running well, no rough idle, hesitation or stalling, you're car is probably fine. Just to be sure take it to an Autozone and have the code pulled. That will tell you for certain if something needs attention.
    This message printed on 100% recycled electrons.

  5. #4
    Registered User
    Join Date
    Nov 2005
    Location
    Glen Spey NY
    Posts
    5
    Thanks for the help. I figured the switch out today before I went to work. I must have accidently switched it on during one of my compulsive daily dust wipes. There wasn't any rough idle or anything. The car will idle at about 1100rpms for a minute or two when you first start it, but then drops to around five or six hundred rpms. Again, thanks for the help.

  6. #5
    Registered User
    Join Date
    Apr 2004
    Location
    Charleston, WV
    Posts
    1,617
    Glad to see you worked it out with nothing being wrong!
    04 PSM WRX Stg 4-16G
    Blobeye Syndicate

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •