Scarey drag launch!! Whats the prob?
Results 1 to 8 of 8

This is a discussion on Scarey drag launch!! Whats the prob? within the Motorsports Talk forums, part of the Community - Meet other Enthusiasts category; Well friday i went to the drag strip for the second time with my 02 cobb stage 2 wrx, sti ...

  1. #1
    Registered User
    Join Date
    Sep 2008
    Location
    Lakeland Florida
    Posts
    14

    Scarey drag launch!! Whats the prob?

    Well friday i went to the drag strip for the second time with my 02 cobb stage 2 wrx, sti up, TBE, injen cai. First time i went i was stage1 and my best was a 14.7@94 with a bog for a launch. Much to my surprise my first run on my second track visit now @ stage 2 was a 14.7@96 with a bad launch again. I am using the gas blip/slip launch method @3-4k which i can get to work on the street but havent had success at thetrack yet. Talking with another subie driver at the track he suggested i blip my throttle between 4/4.5k and slip for a launch.

    Here comes the freaky part.

    Upping the rpms to between 4/4.5k i do a controlled slip launch start going and before you know it my rpms are screaming at 6.5k with my clutch pedal all the way out. I was "moving" but not like i should have something was not right and scared the crap out of me because all this was happening at 6.5k. Anyway i eventually went into second after the "launch" and took it easy down the track. Thinking i had really screwed somthing up i stopped the car and did some inspecting no visable signs of problems but smelled like clutch for about 1/2 hour.

    Was this just my clutch slipping? My car has 70k and this was the first Use of the stage 2 power

    I started the motor again to check it out and everything seemed ok but after ideling for abou 30 sec i noticed white smoke coming out of my exhaust i reved it a little and enough came out for someone to yell "looks like you need new rings!" so i turned the car back off and let it cool a little started it again. This time there was only a little white smoke not near as much and only after it idelled for a bit.

    Is this because of me not having cats? What was up with all the smoke that one time?

    The car ran fine all the way home even launched it after some toll stops and it was strong with no bog or problems. The exhaust has only a little smoke every once in a while after an idel. Probably due to not having cats.

    Where do i go from here? Everything seems fine should i expect to change the clutch soon? Would i be ok to go to the track again?

    Thanks
    2002 WRX wrb

    Cobb AP v1 Stage 2, STI catless uppipe, ERZ 3" catless downpipe, 2.5" supersprint downpipe back exhaust, Injen cold air intake/K&N filter

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    UnBanned Sinister's Avatar
    Join Date
    Nov 2006
    Location
    Denver Metro Area
    Posts
    17,627
    I Support ClubWRX
    Sounds like a multitude of problems.

    White smoke = water vapor.... if it was coming out of the exhaust.

    and it sounds like you have a slipped clutch too.

    Kevin
    Moderator
    Sinister's Blowoff Valve FAQ
    WRX Gas Mileage FAQ
    Sinister's Progress Thread - 430whp 429wtq - Sold
    Firearms Enthusiasts Thread

    The Sheriff's Star at the bottom left corner rates a user's reputation.
    If you found a user's post to be helpful or quite the opposite, please make it known to them by clicking the Star!

  4. #3
    Registered User
    Join Date
    Sep 2008
    Location
    Lakeland Florida
    Posts
    14
    Didnt look like water vapor however it was dark so it was hard to tell if it was bluish or white
    2002 WRX wrb

    Cobb AP v1 Stage 2, STI catless uppipe, ERZ 3" catless downpipe, 2.5" supersprint downpipe back exhaust, Injen cold air intake/K&N filter

  5. #4
    UnBanned Sinister's Avatar
    Join Date
    Nov 2006
    Location
    Denver Metro Area
    Posts
    17,627
    I Support ClubWRX
    Quote Originally Posted by 02rexer View Post
    Didnt look like water vapor however it was dark so it was hard to tell if it was bluish or white
    Bluish is Gas, White is Water, Black is OIL.

    Blue in very small amounts is probably from your lack of a cat, but if it billowed enough for someone to yell at you... It's not just from a cat.
    Kevin
    Moderator
    Sinister's Blowoff Valve FAQ
    WRX Gas Mileage FAQ
    Sinister's Progress Thread - 430whp 429wtq - Sold
    Firearms Enthusiasts Thread

    The Sheriff's Star at the bottom left corner rates a user's reputation.
    If you found a user's post to be helpful or quite the opposite, please make it known to them by clicking the Star!

  6. #5
    Registered User
    Join Date
    Sep 2008
    Location
    Lakeland Florida
    Posts
    14

    Thumbs up

    I do know as a general rule that bluish smoke is oil and black is gas
    2002 WRX wrb

    Cobb AP v1 Stage 2, STI catless uppipe, ERZ 3" catless downpipe, 2.5" supersprint downpipe back exhaust, Injen cold air intake/K&N filter

  7. #6
    UnBanned Sinister's Avatar
    Join Date
    Nov 2006
    Location
    Denver Metro Area
    Posts
    17,627
    I Support ClubWRX
    Quote Originally Posted by 02rexer View Post
    I do know as a general rule that bluish smoke is oil and black is gas
    you are dead correct. I appologize. Got that backwards!
    Kevin
    Moderator
    Sinister's Blowoff Valve FAQ
    WRX Gas Mileage FAQ
    Sinister's Progress Thread - 430whp 429wtq - Sold
    Firearms Enthusiasts Thread

    The Sheriff's Star at the bottom left corner rates a user's reputation.
    If you found a user's post to be helpful or quite the opposite, please make it known to them by clicking the Star!

  8. #7
    Registered User Merk247's Avatar
    Join Date
    Feb 2009
    Location
    catskill ny
    Posts
    192
    i can smell clutch from here..just kidding.. sounds like you just slipped it a bit much hence the smell for 1/2 hour..smoking requires more looking into but with no cats some is normal
    If you have everything under control you're going too slow.
    Bugeye Mafia #218 XPT gm bcs stage 2
    my mods
    HIGH MILEAGE CLUB
    ASE CERTIFIED MASTER TECH.

  9. #8
    Registered User subaru_crazy's Avatar
    Join Date
    May 2004
    Location
    NYC
    Posts
    878
    Sounds like you will be changing out your clutch soon, I had that happen on mine a couple of times when I did a hard launch, even though it was holding up fine in regular driving. However when 70k hit the clutch started letting go and I had to get it changed, no big deal however becasue now I have a brand new stg1 clutch and that sucker holds on tight... now more slipping under hard launches, although I haven't done many from the fear that now my trany will blow up i am t 99k now.
    MY LUG NUTS NEED MORE TORQUE THAN YOUR HONDA MAKES!!!!

    Cobb Stg 2 helix up/dp combo
    Kartboy short shifter

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •