Launch Techniques: READ ME FIRST
+ Reply to Thread
Results 1 to 8 of 8

This is a discussion on Launch Techniques: READ ME FIRST within the Motorsport Stickies forums, part of the Motorsports Talk category; Do not post tips here. Only post helpful URL's or problems with curent listing. http://www.clubwrx.net/forums/showthread.php?s=&threadid=9918 Just so we don't have ...

  1. #1
    Moderator TypeC's Avatar
    Join Date
    Aug 2001
    Location
    Texas
    Posts
    1,249
    I Support ClubWRX

    Exclamation Launch Techniques

    Do not post tips here. Only post helpful URL's or problems with curent listing.

    http://www.clubwrx.net/forums/showthread.php?s=&threadid=9918



    Just so we don't have to have this posted every week

    Those cover the two main ones:
    -Slipping the clutch while holding an rpm
    -Building boost from a low rpm and dropping/slipping from a higher rpm
    Last edited by YBNormal07; 08-22-2007 at 06:12 AM.
    Street Racer Emeritus
    '02 2.5L WRX - Retired

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User renichms's Avatar
    Join Date
    Jun 2003
    Location
    Birmingham, AL
    Posts
    1,777
    Quote Originally Posted by paul nieto
    The problem is you guys are not really explaining it all. Your not mentioning rpm and that has alot to do with it, How high you hold it. There is a difference between a 3000 rpm luanch and a 5000 rpm luanch ,that is the determining factor in a drop luanch with some spin versus a slipping clutch luanch.

    This thread is just for links to launch threads. If you can find the old ones I've lost, you'll see more detail...just have to look for it. For example, you'll find my mentions of 6000 RPM or rev limiter, depending on track.

    RN
    2004 Subaru Impreza WRX STi - WR Blue/Gold wheels
    60': 1.768
    1/4: 13.155 @ 102.02 MPH

  4. #3
    Registered User ryanwrxduksa's Avatar
    Join Date
    Jun 2006
    Location
    NW ct
    Posts
    318
    out of date. atleast the sti thread is. havent checked the others.
    07 white STi in CT

  5. #4
    Registered User jpjester's Avatar
    Join Date
    Apr 2007
    Location
    Doylestown PA
    Posts
    800
    If i put my car in first, hold in the clutch and start reving up the car to try and get high RPMs, the car starts burning the clutch like no other. Plus the car starts to move lol. What am i doing wrong?
    Previous Subarus:
    2004 Subaru WRX, 18G Deadbolt Zilla setup w/ Supporting Mods
    2009 Subaru WRX Hatchback Stock!

  6. #5
    Registered User ryanwrxduksa's Avatar
    Join Date
    Jun 2006
    Location
    NW ct
    Posts
    318
    if your foot isnt all the way at the floor then it sounds like you got air in your clutch system. try bleeding it out.
    07 white STi in CT

  7. #6
    Registered User
    Join Date
    Nov 2007
    Location
    Hartford, Ct
    Posts
    10

    Question 06 sti clutch slip

    Hey
    I just purchased a used 06 sti with 45000 miles on it. First of all I dont know jack on proper shifting and launching, the other day I rev it to 3500 rpm and dropped the clutch and the clutch started slipping and boy did it stink!!! What did I do wrong or does the car need an aftermarket cltch?
    Thanks

  8. #7
    gil
    gil is offline
    Registered User
    Join Date
    Feb 2006
    Location
    Central Jersey
    Posts
    389
    Quote Originally Posted by Explorer31 View Post
    Hey
    I just purchased a used 06 sti with 45000 miles on it. First of all I dont know jack on proper shifting and launching, the other day I rev it to 3500 rpm and dropped the clutch and the clutch started slipping and boy did it stink!!! What did I do wrong or does the car need an aftermarket cltch?
    Thanks
    either you didn't drop the clutch fast enough or your clutch is worn out /glazed and not grabbing . did your tires spin ?

  9. #8
    Registered User
    Join Date
    Nov 2007
    Location
    Hartford, Ct
    Posts
    10

    06 clutch slip

    the tires did not slip, but boy the clutch did. BTW I had the dccs in auto mode. Is that maybe why? I think I also did not drop the clutch fast enough!!!!

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •