View Profile: wrxstar - ClubWRX Forum - Subaru Impreza WRX and STi Community and Forums
Tab Content
No More Results

2 Visitor Messages

  1. Yeah it was my front axle. It only cost like $180 to get fixed though so not too bad.
  2. View Conversation
    sup man, i came across this same issue (your post below)

    OP was about a year ago...but I'm having the same issue in my 03. Doesn't do it everytime. Right when I'm letting the clutch out and giving a little gas it clicks once and is done. I also seem to have a clicking noise on sharp turns at low speed. We just got a new parking garage at work and the sound is amplified now and is bugging me. I'm thinking cv joint for when I turn. But I get the clicking noise when releasing the clutch even when I'm not turning the wheel.

    did you ever find out what happened?

    thanks
Showing Visitor Messages 1 to 2 of 2
About wrxstar

Basic Information

About wrxstar
Your Vehicle(s):
2003 Impreza WRX
Location:
Idaho
Engine/Transmission mods:
catless up, invidia DP, cobb ap
Suspension/Wheels mods:
Eibach pro kit. 17" Rota Torque
Approximate $ Spent Modifying Your Car:
0
Gender:
Male

Signature


03' bugeye, helix up, invidia DP, eibach springs, cobb stage 2

Statistics


Total Posts
Total Posts
75
Posts Per Day
0.03
Visitor Messages
Total Messages
2
Most Recent Message
09-17-2009 06:08 AM
General Information
Last Activity
04-10-2011 08:31 PM
Join Date
06-23-2007
Referrals
0
iTrader Profile Recent Ratings
Feedback Score:
Positive Feedback:
0
0%
Members who left positive:
Members who left negative:
0
0
Total positive feedback: 0
Submit Feedback For wrxstar
View Complete Feedbacks for wrxstar
  Past
Month
Past
6 Months
Past
12 Months
  0 0 0
  0 0 0
  0 0 0