Conversation Between Timdog1650 and wrxmuch?

Conversation Between Timdog1650 and wrxmuch?

4 Visitor Messages

  1. Glad to hear it. It's always something simple...
  2. Problem SOLVED!!!!!


    Took it down to Alabama to a tuner. Static-x motorsports *really nice guys that really know their stuff* checked my car out completely. Then said i needed to take the car to Subaru to read a Subaru only code. Took it over there and they said "blah blah blah, Stage 2, blah blah blah, Turn it back to stock blah blah blah. You know how it is. Any way..... They said the exhaust gas temp was 2084 degrees!!!!!!! My tuner said if that was the case then my engine should be liquid metal! *normally pistons turn to mush at 1800. Disconnected EGT sensor and problem solved!!!! Turns out the egt sensor is only used to make sure that I'm not burning up my cats. Too bad i don't have cats. I got the tip from a post that said that the EGT sensor has a tendency to break off and give faulty readings! Thank god i found out why.....
  3. No, you should be running stock heat range OEM iridium or copper plugs. Once you've added about 120hp to the crank you can start thinking about different plugs, but 9 times out of 10 the stock plugs are going to work best.
  4. thanks for replying to my cars blinking cel problem post. I had a question though. Would the blinking cel happen due to the fact that i'm running stage 2 cobb while running BKR6EIX instead of bkr7eix? I know that the 7eix is one step colder and i'm running about 70 hp over stock
Showing Visitor Messages 1 to 4 of 4