View Profile: smurf976 - ClubWRX Forum - Subaru Impreza WRX and STi Community and Forums
Tab Content
No More Results

1 Visitor Messages

  1. HELP, I jusy got my subie and while I was wiring the turbo timer to the ecu I notived a **** load of electrical tape on alot of the wires. some one had some **** in my care and I dont know what it was. Im throwing the check engine light for the o2 sensor bank one sensor 2. I researched the net and found several problems. The first was a jumper wire between the blue and white wire on the sensor wire its self. next was a exaust leak on the stock exausts manifuld. I fixed both problems and Im still throwing the check engine light. Im now trying the ecu reset but its raining and I have a cold air intake. So Im not going to be able to take it to redline. Also Ive heard that a intake without tunning is bad. Should I take it out? Will it hurt my car? talk to me!!!
Showing Visitor Messages 1 to 1 of 1
About smurf976

Basic Information

About smurf976
Your Vehicle(s):
2004 impreza
Location:
CA
Estimated HP:
un known
Engine/Transmission mods:
I have intake and a up pipe
Suspension/Wheels mods:
skunk 2 springs
Audio/Electronics:
apex turbo timer
Future plans:
cobb tuner/ cobb exaust
Interests:
photography
Occupation:
hvac/sheet metal
Gender:
Male
Your Name:
Adam

Statistics


Total Posts
Total Posts
15
Posts Per Day
0.01
Visitor Messages
Total Messages
1
Most Recent Message
05-01-2009 07:53 PM
General Information
Last Activity
09-10-2010 02:58 PM
Join Date
05-01-2009
Referrals
0
iTrader Profile Recent Ratings
Feedback Score:
Positive Feedback:
0
0%
Members who left positive:
Members who left negative:
0
0
Total positive feedback: 0
Submit Feedback For smurf976
View Complete Feedbacks for smurf976
  Past
Month
Past
6 Months
Past
12 Months
  0 0 0
  0 0 0
  0 0 0