View Profile: Forever022 - ClubWRX Forum - Subaru Impreza WRX and STi Community and Forums
No More Results

1 Visitor Messages

  1. View Conversation
    Sorry I didnt' reply sooner. I don't get notifications anymore from this site. I've had 3 struts replaced under warranty. This was when I was driving it a lot more than I do now. First time it was both rear struts. Then the second it was only the back left, or right. I don't remember. I'm finding now, that I'm experiencing the same sticking strut problem whenever I push the car a little bit. But I might drive it once a week now, so it just doesn't bother me enough to pay for a new strut now that I'm well out of my warranty. Try lubricating the shaft. I'm not sure exactly what type of lube to use, but give subaru a call and find out what they use. From what I remember, the strut issue I had stemmed from a lack of lubrication on one of the bushings.
Showing Visitor Messages 1 to 1 of 1
About Forever022

Basic Information

About Forever022
Your Vehicle(s):
Subaru 04 STi
Interior/Exterior/Accessories:
Sunroof, Body Kit
Audio/Electronics:
DVD, GPS, 2x 12"
Approximate $ Spent Modifying Your Car:
5000
Gender:
Male

Statistics


Total Posts
Total Posts
1
Posts Per Day
0.00
Visitor Messages
Total Messages
1
Most Recent Message
04-16-2009 11:57 AM
General Information
Last Activity
12-03-2008 02:25 PM
Join Date
12-03-2008
Referrals
0
iTrader Profile Recent Ratings
Feedback Score:
Positive Feedback:
0
0%
Members who left positive:
Members who left negative:
0
0
Total positive feedback: 0
Submit Feedback For Forever022
View Complete Feedbacks for Forever022
  Past
Month
Past
6 Months
Past
12 Months
  0 0 0
  0 0 0
  0 0 0