2003 Subaru Impreza WRX Club Spec Evo 6 Passenger H1 Low Beam problem Blob Eye/Peanut
+ Reply to Thread
Results 1 to 3 of 3

This is a discussion on 2003 Subaru Impreza WRX Club Spec Evo 6 Passenger H1 Low Beam problem Blob Eye/Peanut within the Maintenance, service, and repair forums, part of the Tutorials & DIY category; hi guys I've got a problem this is my first time posting so bear with me i've replaced the H1 ...

  1. #1
    Registered User ArcadeObsessed's Avatar
    Join Date
    Jul 2016
    Posts
    2

    2003 Subaru Impreza WRX Club Spec Evo 6 Passenger H1 Low Beam problem Blob Eye/Peanut

    hi guys I've got a problem this is my first time posting so bear with me

    i've replaced the H1 low beam and H3 spotlights many many times before

    H3 is fine always

    this time around my passenger H1 low beam will not turn on

    i've checked the left-hand fuse

    tried 2 of the same globe there both fine and not blown

    i'm in Melbourne Australia I have no idea why it's not working any help would be great

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Water.....sometimes waves rqjoe's Avatar
    Join Date
    Feb 2015
    Location
    Ohio
    Posts
    1,110
    I Support ClubWRX
    Did the old bulb work then just not a new one? Very odd. I'd make sure the contacts on new vs old bulbs are the same then get out my multimeter and start checking for power....

  4. #3
    Registered User ArcadeObsessed's Avatar
    Join Date
    Jul 2016
    Posts
    2
    all good guys worked out what the problem is the gold terminal positive lead I just crimped it a bit harder and it was fine

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Please select your insurance company (Optional)

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •