CEL P0457 Madness, 2005 WRX
+ Reply to Thread
Results 1 to 9 of 9

This is a discussion on CEL P0457 Madness, 2005 WRX within the Maintenance, service, and repair forums, part of the Tutorials & DIY category; Hey guys, been a long time since I've posted on here. I am starting this new thread because anytime I ...

  1. #1
    Registered User 05BlackBeauty's Avatar
    Join Date
    Feb 2007
    Location
    C-Reach Strong Isle
    Posts
    225

    Cool CEL P0457 Madness, 2005 WRX

    Hey guys, been a long time since I've posted on here. I am starting this new thread because anytime I search for an answer I cant find anything pertaining to a 2005. My car is a 2005 WRX and I keep getting a trouble code for the evap system (either fuel cap loose/off, or small evap leak). Luckily I have the accessport so I can diagnose and clear the codes, however I am tired of it coming back every so often (when I highway drive I can get the car to cycle through the diagnosis test and it triggers the CEL). I have taken several steps in an attempt to diagnose the issue myself and Ive been unsuccessful thus far. I have replaced the gas cap with a new OEM Subaru part, I have checked all hoses and fittings connecting to the Purge Control Solenoid valve next to the intake manifold in the engine compartment, Ive even pulled the charcoal canister to inspect for split/cracked hoses and to check the pressure control solenoid mounted above. I modded the car about 8 years ago (Walboro fuel pump included), and never had this issue until about a year and a half ago. This is driving me mad as I keep my car meticulous and Im also due for inspection in about a month so I need to make sure the code doesn't keep re-occurring. The only other information I have related to this issue is that I can pick up on a faint scent of fuel when I am near the fuel door/passenger side rear area of the car. I understand that there are several moving parts involved in the evap emissions control system and I am fairly certain of the ones that I have ruled out so far. I can see that a good amount of people have experienced the same issues with their WRX. Any insight or suggestions are welcome Thanks in advance!!

    -Rob
    OBP 05 WRX sedan, Big Evo III 16G, STi 565 injectors, HKS S-type FMIC, HKS super mega flow intake, Walbro FP, Helix catted DP, HKS UP, SRS catback and so much more.....

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Water.....sometimes waves rqjoe's Avatar
    Join Date
    Feb 2015
    Location
    Ohio
    Posts
    727
    I Support ClubWRX
    Sounds like a duplicate of a problem I had on an old 2000 Regal. Mine ended up being a rusted-through fuel-fill neck/pipe just behind the plastic when you open the fuel door. I RTV'd it once but that didn't hold long and eventually I had to have the filler pipe replaced.

  4. #3
    Actually a SuperSpy. Take Care. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    26,090
    I Support ClubWRX
    WRX Info Links, Courtesy TheJ
    Πως έγινε με τούτο τον αιώνα και γύρισε καπάκι η ζωή
    Πως το ’φεραν η μοίρα και τα χρόνια να μην ακούσεις έναν ποιητή
    Manos Eleftheriou
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  5. #4
    Registered User 05BlackBeauty's Avatar
    Join Date
    Feb 2007
    Location
    C-Reach Strong Isle
    Posts
    225
    All the lines and T-splicing routed to the Purge Control Solenoid near the intake manifold are intact. Might look at the filler neck though conisdering I live in the rustbelt and havent done so yet

    Sent from my SAMSUNG-SM-G890A using Tapatalk
    OBP 05 WRX sedan, Big Evo III 16G, STi 565 injectors, HKS S-type FMIC, HKS super mega flow intake, Walbro FP, Helix catted DP, HKS UP, SRS catback and so much more.....

  6. #5
    Actually a SuperSpy. Take Care. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    26,090
    I Support ClubWRX
    OK then yes it's worth a look at the filler. I've not lived in the rustbelt in ages and have lost the ability to even suspect rust as an issue out here. Sometimes there are even physical clogs (spider webs etc.) that may trigger the CEL too. Look for anything unusual.

    Oh, about the blue T: Mine had a crack at the T itself and it was just barely visible. I had to look closely. I'd not have guessed it's anything to do with the purge valve but it was after all. No matter where you are looking I'd have a patient second look.
    WRX Info Links, Courtesy TheJ
    Πως έγινε με τούτο τον αιώνα και γύρισε καπάκι η ζωή
    Πως το ’φεραν η μοίρα και τα χρόνια να μην ακούσεις έναν ποιητή
    Manos Eleftheriou
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  7. #6
    Registered User 05BlackBeauty's Avatar
    Join Date
    Feb 2007
    Location
    C-Reach Strong Isle
    Posts
    225
    Sounds worth a second glance....thanks man

    Sent from my SAMSUNG-SM-G890A using Tapatalk
    OBP 05 WRX sedan, Big Evo III 16G, STi 565 injectors, HKS S-type FMIC, HKS super mega flow intake, Walbro FP, Helix catted DP, HKS UP, SRS catback and so much more.....

  8. #7
    Registered User 05BlackBeauty's Avatar
    Join Date
    Feb 2007
    Location
    C-Reach Strong Isle
    Posts
    225
    Alright Ive traced an issue to the fuel tank itself. I removed the plastic safety cover for the filler neck and everything appears to be A Ok there upon inspection. However I did notice caked up fuel on the upper part of the tank. I opened the access hatch in the trunk for the fuel pump and low and behold there is grimed up fuel on top of the tank. Im thinking the gasket where the pump/sending unit seats to the tank may have taken a dump is causing vapor leak from the tank, hence the raw fuel smell every now and again. Its an easy swap and a relatively cheap part so I think im gonna go for it. I recall reading somewhere a faulty gasket could cause this code to appear. Sound legit?

    Sent from my SAMSUNG-SM-G890A using Tapatalk
    OBP 05 WRX sedan, Big Evo III 16G, STi 565 injectors, HKS S-type FMIC, HKS super mega flow intake, Walbro FP, Helix catted DP, HKS UP, SRS catback and so much more.....

  9. #8
    Water.....sometimes waves rqjoe's Avatar
    Join Date
    Feb 2015
    Location
    Ohio
    Posts
    727
    I Support ClubWRX
    Yeah, any leak in the tank cavity can cause that code. Leak downstream of the pump (low fuel press) woud be diff code though. Glad u found it. I have had fuel pumps go in several vehicles but never that gasket.

  10. #9
    Registered User 05BlackBeauty's Avatar
    Join Date
    Feb 2007
    Location
    C-Reach Strong Isle
    Posts
    225
    Wound up getting the gasket, pulling the fuel pump and cleaning that all up and reseating it. So far so good....no more smell of gas fumes upon fill-up
    OBP 05 WRX sedan, Big Evo III 16G, STi 565 injectors, HKS S-type FMIC, HKS super mega flow intake, Walbro FP, Helix catted DP, HKS UP, SRS catback and so much more.....

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Please select your insurance company (Optional)

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •