help please
Results 1 to 2 of 2

This is a discussion on help please within the Maintenance, service, and repair forums, part of the Tutorials & DIY category; P1096 Tumble Generator valve circuit #2 (open circuit) Can someone please explain to me what this is? I have an ...

  1. #1
    Registered User wagon_bud's Avatar
    Join Date
    Nov 2007
    Location
    Buena Park
    Posts
    11

    help please

    P1096 Tumble Generator valve circuit #2 (open circuit)
    Can someone please explain to me what this is?

    I have an 02 wagon. My car is currently sitting in my driveway ****ty. Something has gone terribly wrong. When I take of properly my seems to run all right. When I step on the gas to accelerate quickly at around 3000rpm's something slips and my rpm's spike and i have to let off the gas in order for whatever is ****ed up to re-engage. Im not sure if its the clutch, the tranny, or whatever the heck that code is above. Can someone please help this is killin me

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Moderator YBNormal07's Avatar
    Join Date
    Jul 2003
    Location
    PA
    Posts
    6,244
    I Support ClubWRX
    No idea what is causing the tgv CEL code. The RPM's rising while trying to acclerate is a sure sign of a clutch getting ready to let go. You'll need your clutch replaced ASAP. Baby it until you get this done, otherwise you could be left stranded if it decides to give out completely.
    tEh PriUs=teH faSTah!@@!
    08 Audi S5 Black Diamond edition
    SOLD: 05 SWP Legacy GT Limited 5MT, 13.3ish@105 (stage 2) crappy stock clutch
    SOLD: 04 MPS/SW WRX Sti. 12.971 @ 103.97 (stock)
    278 AWHP/283 AWT, Catback exhaust
    306 AWHP/341 AWT, Stage 2
    (Scott) Moderator-STi, Drag Racing, Car Purchasing, and Tutorial Forums

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •