Trunk Release
Results 1 to 8 of 8

This is a discussion on Trunk Release within the Interior Mods forums, part of the Tech & Modifying & General Repairs category; I was coming back from lunch today, and I tried to open my trunk using the release lever and it ...

  1. #1
    Registered User
    Join Date
    Aug 2004
    Location
    Jericho, Long Island
    Posts
    163

    Trunk Release

    I was coming back from lunch today, and I tried to open my trunk using the release lever and it didn't work. It worked about a half hour before. Could it be a cable that went? The trunk works with a key, but now the lever doesn't work. Also, it is a 2002 WRX
    LISC #16

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User uncle lewie wrx's Avatar
    Join Date
    Oct 2004
    Posts
    4,936
    go back and try it again later, sometimes i find that it'll work fine for a given time, then randomly i'll pull on the lever a few times and nothing happens. Go back and it works again.
    uncle lewie
    06 Aspen White STi w/ Gold BBS's

  4. #3
    Registered User
    Join Date
    Dec 2003
    Location
    Hilliard, OH
    Posts
    345
    Open it with the key, then right where the latch is (I'm pretty sure that's where it is) there is a locking mechanism. Flip that lock to the other side and check it again with the lever in the car...same thing happened to me over the summer at a golf tournament and I thought for sure I wasn't going to be able to get my clubs out of the trunk.

  5. #4
    Registered User uncle lewie wrx's Avatar
    Join Date
    Oct 2004
    Posts
    4,936
    i gotta check that out tommorow. sweet tip.
    uncle lewie
    06 Aspen White STi w/ Gold BBS's

  6. #5
    Registered User
    Join Date
    Aug 2004
    Location
    Jericho, Long Island
    Posts
    163
    thanks for the tips, i am going to go check that out now.
    LISC #16

  7. #6
    Registered User
    Join Date
    Aug 2004
    Location
    Jericho, Long Island
    Posts
    163
    thanx for the advice...it works
    LISC #16

  8. #7
    Registered User
    Join Date
    Dec 2003
    Location
    Hilliard, OH
    Posts
    345
    Good to hear!

  9. #8
    Registered User STiguy's Avatar
    Join Date
    Jan 2004
    Location
    Long Island, New York
    Posts
    1,670
    haha, same thing happened to me
    LISC #1
    05 STi - 300whp 331wtq 1/4 - 12.7 @107.4 (SOLD)
    06 Evo IX 370whp 386wtq (Under Construction)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •