HVAC bulbs
Results 1 to 6 of 6

This is a discussion on HVAC bulbs within the Interior Mods forums, part of the Tech & Modifying & General Repairs category; was doing my HVAC mod and now i need 3 new bulbs cause the stock ones wont lite up. so ...

  1. #1
    Registered User
    Join Date
    May 2004
    Location
    Houston
    Posts
    80

    HVAC bulbs

    was doing my HVAC mod and now i need 3 new bulbs cause the stock ones wont lite up. so does anyone know where i can find replacments besides the dealership that sells them for 8 dollars a bulb. thanks.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User GetawayInBouldr's Avatar
    Join Date
    Feb 2004
    Location
    A Whales Va-jay-jay
    Posts
    1,100
    autolumination.com
    ~ Silver Wagon Club ~

  4. #3
    Registered User
    Join Date
    May 2004
    Location
    Houston
    Posts
    80
    by anychance do you know the exact size? i dont know if the bulb can be pulled out of the little black socket thing but i believe the socket thing is nto making contack to something keeping it from lighting up.

  5. #4
    Registered User GetawayInBouldr's Avatar
    Join Date
    Feb 2004
    Location
    A Whales Va-jay-jay
    Posts
    1,100
    The bulb should come right out of the socket. Sometimes it takes a pretty good tug, but it'll come. I actually grabbed the bulb with a pair of needle nose plyers (carefully) and yanked it out, which tore the bulb condom in the process. You should try pulling the bulbs out and playing with the them a bit to make sure they are making a good connection with the socket. It is very unlikely that all 3 bulbs went out at the same time. It is more likely that a fuse blew or they aren't making a good connection. The size bulb my WRX HVAC takes is 194. Click here. I'm not 100% positive it's the same size in the STi, but I think it is. Double check the size with your dealership if you do end up ordering some new bulbs.

    What HVAC mod are you taking about? Are you changing the color of the bulbs or are you doing something different?
    ~ Silver Wagon Club ~

  6. #5
    Registered User
    Join Date
    May 2004
    Location
    Houston
    Posts
    80
    i have 4 bulbs, 1 works so i tested it by switching places with the ones that went out and it still lights, the bulb is inside some black casing or something where when you remove the bulb you go from the back and use a phillips and twist it and pull out. it doesnt look like a 194 to me more like a 74 inside a tube.

  7. #6
    Registered User GetawayInBouldr's Avatar
    Join Date
    Feb 2004
    Location
    A Whales Va-jay-jay
    Posts
    1,100
    Doh! Sorry man, it is a 74. Somepeople were cutting the 194's to fit into the sockets that take 74's, but it didn't really produce any more light than the 74's.

    In my WRX, the HVAC takes 2 bulbs size 74 and I put two red bulb condoms on them to make the red appearance, but it came out more red-orange.

    It sounds like to me you have a different setup than I do. Got a digi cam? Try and take some pictures and post'em up if you can.
    ~ Silver Wagon Club ~

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •