Need help with HKS TT
Results 1 to 10 of 10

This is a discussion on Need help with HKS TT within the Interior Mods forums, part of the Tech & Modifying & General Repairs category; Got the turbo timer on Friday. Install went fine. I didn't hook up thr RPM wire yet, and that might ...

  1. #1
    Registered User Werrxxx's Avatar
    Join Date
    Jun 2004
    Location
    Stamford, CT
    Posts
    74

    Need help with HKS TT

    Got the turbo timer on Friday. Install went fine. I didn't hook up thr RPM wire yet, and that might be the source of my problem. Also, there are instructions of looping the grey wire from the Turbo Timer if you don't hook it up to your e-brake. Basically the turbo timer works for everything except keeping the engine running after I take out the key. Well, I should say it runs for literally 1 second before shutting off. even if i set the timer to 1:30. Any ideas?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User Werrxxx's Avatar
    Join Date
    Jun 2004
    Location
    Stamford, CT
    Posts
    74
    anybody? I'm desperate here

  4. #3
    Registered User Family Guy's Avatar
    Join Date
    Jul 2003
    Location
    Memphis TN
    Posts
    982
    I had the same problem. I had a problem with the Diode in the E-Brake wire (which allows electricity to only flow one way through the wire). I took mine out and worked fine and has for over a year now.
    Now: 04 WRB STi (stock)

  5. #4
    Registered User Werrxxx's Avatar
    Join Date
    Jun 2004
    Location
    Stamford, CT
    Posts
    74
    I haven't hooked up the e-brake wire yet. I just looped it cause it said loop the grey wire if you don't hook it to the e-brake wire. Maybe i'm just confused. I'm just gonna suck it up and hook up the e-brake and rpm wires tonight. Hopefully that will solve the problem. Thanks for your input!

  6. #5
    Registered User Family Guy's Avatar
    Join Date
    Jul 2003
    Location
    Memphis TN
    Posts
    982
    From what I remember you have to hook up the e-brake wire. otherwise the car will always assume the ebrake is down and will not keep the car running. It gets 12v from the ebrake that tells the timer the ebrake is up.
    Now: 04 WRB STi (stock)

  7. #6
    Registered User Werrxxx's Avatar
    Join Date
    Jun 2004
    Location
    Stamford, CT
    Posts
    74
    OK hooked up the e-brake wire and everything else. TT works fine, but now my auto-lock remote won't work during count-down. anyone else run into this problem?

  8. #7
    Registered User Family Guy's Avatar
    Join Date
    Jul 2003
    Location
    Memphis TN
    Posts
    982
    That is because you are trying to arm the car with it running which it cannot do. Search around here under turbo timer and alarm and someone had pretty good instructions on how to make it work.
    Now: 04 WRB STi (stock)

  9. #8
    Registered User GotRice7169's Avatar
    Join Date
    Jun 2003
    Location
    Tampa Florida
    Posts
    420
    i have all the wires hooked up ( i think, the red splice thingies dont seem to splice very well) and the turbo timer turns off with the car, and the car justhesitates to shut off.

    also, on the timer thing when it says 1.30 sec, is that 1.30 seconds or 1 minute and 30 seconds?
    My Mods w/ Pics

    13.57 @ 100.9 mph

    UCF Car Club

  10. #9
    Registered User Werrxxx's Avatar
    Join Date
    Jun 2004
    Location
    Stamford, CT
    Posts
    74
    minute thirty.

  11. #10
    Registered User GotRice7169's Avatar
    Join Date
    Jun 2003
    Location
    Tampa Florida
    Posts
    420
    ok thats what i thought. fixed the problem, the wires splicers HKS gave are crap, bought some new ones, works great. but now when i arm the alarm and walk away, my exhaust will make it go off sometimes. anyone know a way to desensitize the alarm, or maybe delay it a minute or so?
    My Mods w/ Pics

    13.57 @ 100.9 mph

    UCF Car Club

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •