04 USDM STi Cluster in 02 WRX
Results 1 to 10 of 10

This is a discussion on 04 USDM STi Cluster in 02 WRX within the Interior Mods forums, part of the Tech & Modifying & General Repairs category; I think I have read every thread in three different forums so I figured I'd just ask. Does anyone, who ...

  1. #1
    Registered User aem421's Avatar
    Join Date
    Sep 2002
    Location
    MD
    Posts
    350

    Question 04 USDM STi Cluster in 02 WRX

    I think I have read every thread in three different forums so I figured I'd just ask. Does anyone, who has installed a USDM STi Cluster in their WRX, know if there is a fix to get the DCCD and Rear Diff Temp lights to not come on? There are some really good threads on this subject but I have yet to read where someone has corrected those two problems.

    I'm asking because I just got a sweet deal on an STi Cluster and I've decided to replace my '02 stock gauge cluster (even though I just got them to look awesome in red...yeah I'm crazy). Any help on this would be greatly appreciated as always. Thanks.
    '02 WRX/STi

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User aem421's Avatar
    Join Date
    Sep 2002
    Location
    MD
    Posts
    350
    bump...anyone?
    '02 WRX/STi

  4. #3
    Registered User
    Join Date
    May 2004
    Posts
    267
    Quote Originally Posted by aem421
    bump...anyone?
    Take out the lights.

  5. #4
    ClubWRX.net Vendor
    Join Date
    Mar 2004
    Location
    Los Angeles
    Posts
    494
    I swapped to a '04 WRX cluster, RPM is in the middle where it should've been in the '02. Airbag light was on. I just covered it with electrical tape behind the thin black plastic piece with all the readouts on them.

    But then, I could've just used a resistor, but I didn't know that at the time.
    Those fools, EVO vs. STi??? That's like comparing ....wait a minute...there's no comparison. The Suby's still working!!! The evo...well... I hope he got the extended warranty.

  6. #5
    Registered User
    Join Date
    Jun 2004
    Location
    Houston
    Posts
    16

    DCCD in wrx?

    are you saying you installed the sti's dccd in your rex?


    Quote Originally Posted by aem421
    I think I have read every thread in three different forums so I figured I'd just ask. Does anyone, who has installed a USDM STi Cluster in their WRX, know if there is a fix to get the DCCD and Rear Diff Temp lights to not come on? There are some really good threads on this subject but I have yet to read where someone has corrected those two problems.

    I'm asking because I just got a sweet deal on an STi Cluster and I've decided to replace my '02 stock gauge cluster (even though I just got them to look awesome in red...yeah I'm crazy). Any help on this would be greatly appreciated as always. Thanks.
    Got Boost?

  7. #6
    Registered User aem421's Avatar
    Join Date
    Sep 2002
    Location
    MD
    Posts
    350
    No, I didn't install the DCCD, just the STi gauge cluster. When you do that, the DCCD light on the dash and the Rear Diff Temp light on the dash, stay lit. I was wondering if anyone figured out how to get them to turn off.
    '02 WRX/STi

  8. #7
    Registered User bluerex47's Avatar
    Join Date
    Jun 2004
    Location
    ohio/texas
    Posts
    2,301
    Quote Originally Posted by subieworx
    Take out the lights.
    simple as this. you don't have dccd or rear diff temp so you don't need the lights. so instead of all the resistors and such, just take out the lights
    - chris
    04 wrx, 04 corvette, 66 GTO
    ACT installed at 36k...new Gears at 44k...

  9. #8
    Registered User aem421's Avatar
    Join Date
    Sep 2002
    Location
    MD
    Posts
    350
    I looked at the cluster in detail. It's almost impossible to take out the lights. I'm too afraid to even fool with it because I don't want to break a $500 piece of equipment. It's way easier to just slip in a piece of electrical tape to cover up the back of the gauge plates. I think I'll do that for now until someone comes up with a better solution. Thanks guys.
    '02 WRX/STi

  10. #9
    Registered User reallove325's Avatar
    Join Date
    Sep 2004
    Location
    nc
    Posts
    220

    tape it!!

    tape it or leave them alone. i just left mine alone so every time a chick gets in my car i can tell her they are important chicks dig them!

  11. #10
    Registered User Colorado Rexer's Avatar
    Join Date
    Feb 2004
    Location
    Longmont, CO
    Posts
    714
    anyone know where I can find a good tutorial on how to install a 8 STI CLuster in an 04 WRX?

    Thanks.....I tried seaching but am not having much luck
    Once upon a time I had a unique sig.....that time has passed. Now my sig is bland and boring like Cream Of Wheat without butter or sugra. Bleh.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •