Got my system installed...day later it blows!! - Page 2
Page 2 of 2 FirstFirst 12
Results 16 to 17 of 17

This is a discussion on Got my system installed...day later it blows!! within the Interior Mods forums, part of the Tech & Modifying & General Repairs category; You should be giving me discounts! Just don't sell me faulty products and I won't return them Funny, but with ...

  1. #16
    Registered User Blue2004WRX's Avatar
    Join Date
    Jul 2003
    Location
    Syracuse NY
    Posts
    1,039
    You should be giving me discounts! Just don't sell me faulty products and I won't return them

    Funny, but with my cars, I've never had any problems like he had.

    What do you sell?
    --2004 WRB WRX--
    Still way too stock.

    Originally posted by MidnightFLAT4
    I like A/C for the sole reason that it makes the idle sound meaner.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #17
    ClubWRX.net Vendor
    Join Date
    Mar 2004
    Location
    Los Angeles
    Posts
    494
    if you've heard about it, I'm most likely a dealer. The only one I can't have is Alpine, Al and Ed's is down the street from me, but their end is near, and I'm not a factory direct Sony dealer. With horrble service, bad merchandise and no VIR programs, I can't think of any good reason to support their line.
    Those fools, EVO vs. STi??? That's like comparing ....wait a minute...there's no comparison. The Suby's still working!!! The evo...well... I hope he got the extended warranty.

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •