So I got Omori gauges a few weeks after Christmas and installed them myself within the next week. My oil pressure and boost gauge have been working great since the install but my EGT has never worked. J-Spec sent me another sensor to try.. didn't fix the problem. I sent my gauge to them to fix because they forgot to send me a new one; just got it back yesterday... still doesn't work. There's power running to the gauge and it lights up but the needle just sits at the most extreme point whenever the car's running and doesn't move. All my gauges are wired together under the fuse panel then are wired into the clock, and grounded to the metal bar under the dash. Yesterday I wired up the EGT by itself and ran the ground directly to the negative terminal on the battery, still same damn results. This is driving me nuts now, since I haven't had an EGT gauge for almost 7 months now. Anybody know what I could try to do to check if there's a faulty ground in the harness or something. It seems like that would be the problem but I can't figure out how since I've double and triple checked. Sorry for the long explanation but I need help! -Matt