Please Help! (Already did a search)
Results 1 to 7 of 7

This is a discussion on Please Help! (Already did a search) within the Interior Mods forums, part of the Tech & Modifying & General Repairs category; Ok so I just ripped my cluster out and got the white face guages on without breaking or bending the ...

  1. #1
    Registered User Stealththx's Avatar
    Join Date
    Feb 2004
    Location
    Channahon, Illinois
    Posts
    219

    Please Help! (Already did a search)

    Ok so I just ripped my cluster out and got the white face guages on without breaking or bending the needles (hopefully). Ok so I have two plugs that come from each side of the cluster. One is to light the temp/gas side the other is for the tach/speed side. Now I got this strage looking harness that came with it and I'm not sure where I am supposed to plug this stuff in at. Here are some pictures to help

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User Stealththx's Avatar
    Join Date
    Feb 2004
    Location
    Channahon, Illinois
    Posts
    219
    So here is the whole thing. On the upper right I have the red power wire (which connects to the purple on the cluster?) and Black ground. The upper right is just the color selector. The part I don't understand id the 4 plugs. I only have a place to plug two in. What do you do with the other two?
    Attached Thumbnails Attached Thumbnails 108-0805_img.jpg  

  4. #3
    Registered User Stealththx's Avatar
    Join Date
    Feb 2004
    Location
    Channahon, Illinois
    Posts
    219
    The 4 plugs up close that plug into the actual white face gagues. Only 2 are used.
    Attached Thumbnails Attached Thumbnails 108-0806_img.jpg  

  5. #4
    Registered User power091999's Avatar
    Join Date
    Jul 2003
    Posts
    1,133
    The black wire with the round connector is your ground. I believe the other cables coming off should attach to the wires coming from the new white gauges.

    Red cable should be your power, connect that to your parking light wire.

    And the rotator should be for brightness, or color change. Or both.

  6. #5
    Registered User Stealththx's Avatar
    Join Date
    Feb 2004
    Location
    Channahon, Illinois
    Posts
    219
    Ok so, I finally got the wires connected but now I am trying to get the cluster back in the dash and it is a pain in the a$$! Are there any secrets or tips of getting the steering wheel out of the way and making this easier?

  7. #6
    Registered User Stealththx's Avatar
    Join Date
    Feb 2004
    Location
    Channahon, Illinois
    Posts
    219
    OK I finished putting the cluster back in and now when I go to put the key in the ignition it will not turn! What is next? Why can't I start my car??? Please help.

  8. #7
    Registered User power091999's Avatar
    Join Date
    Jul 2003
    Posts
    1,133
    Your key won't turn?

    Well try this.

    1. Make sure steering wheel isn't locked
    to do this turn the wheel and the key at the same time.

    2. Make sure that the plastic around the steering column isn't
    rubbing aginst the key slot.

    3. Try to tourque on the key a bit more than usual.

    Good luck.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •