escort radar question
Results 1 to 14 of 14

This is a discussion on escort radar question within the Interior Mods forums, part of the Tech & Modifying & General Repairs category; i have a question on my radar detector. i have a passport 8500 and every time i go upbove 5000 ...

  1. #1
    Registered User
    Join Date
    Feb 2004
    Location
    rockledge, fl.
    Posts
    9

    Question escort radar question

    i have a question on my radar detector. i have a passport 8500 and every time i go upbove 5000 rpm my laszer go off? i was woundering if any one ealse is having this trouble or know what is causeing it?.....dan

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User cnstman's Avatar
    Join Date
    Jan 2002
    Location
    Colorado Springs
    Posts
    986
    i have one also and mine does not do it. interesting.

    anyone else?
    2004 STi
    Silver/Silver

  4. #3
    Registered User BlueSubie02's Avatar
    Join Date
    Jun 2003
    Location
    South FL
    Posts
    1,712
    Originally posted by cnstman
    i have one also and mine does not do it. interesting.

    anyone else?

  5. #4
    cnk
    cnk is offline
    Registered User
    Join Date
    Jul 2002
    Location
    NJ
    Posts
    766
    Do you have an older unit? There was an issue a while back with earlier units where the voltage through the cigarette adapter triggered false alarms. The fix was a newer cigarette adapter.

    Calvin

  6. #5
    Registered User JT-555's Avatar
    Join Date
    Apr 2003
    Location
    Atlanta, Ga
    Posts
    24
    i have an 8500 but no laser problem.
    seems like this was asked before.
    -------=======>>>>>
    '03 Blue sedan.
    Pretty much it.

  7. #6
    Registered User ma1ade's Avatar
    Join Date
    Dec 2003
    Location
    Eastern CT and Quantico VA
    Posts
    332
    Originally posted by cnstman
    i have one also and mine does not do it. interesting.

    anyone else?

  8. #7
    Registered User SupraToWRX's Avatar
    Join Date
    Jun 2003
    Location
    South NJ / Philly
    Posts
    229
    I have the same detecter here and have no problems.
    '04 WRB WRX Sedan

  9. #8
    Registered User
    Join Date
    Apr 2003
    Location
    Elgin, IL
    Posts
    5
    I use to have a cheap radar detector from radio shack, and I would get false laser readings whenever I would accelerate. I recently got a whislter de1793, and the problem was solved. However, in the user manual they said false laser detections while accelerating could be caused by a faulty or low quality distributor cap. Just something to look into.

  10. #9
    Registered User Salient's Avatar
    Join Date
    Apr 2003
    Location
    Racine, WI.
    Posts
    144
    Damn, sounds like a built in rev limiter. Perhaps Escort did it, thinking "if this guy is hitting 5K, then we should scare the **** outta him."


  11. #10
    Moderator MidKnight's Avatar
    Join Date
    Oct 2002
    Location
    Bergen, NJ
    Posts
    4,711
    I Support ClubWRX
    Originally posted by SupraToWRX
    I have the same detecter here and have no problems.
    '03 WRX
    '01 2.5RS
    MODS | PICS | Dyno
    "Stuff sold by the gram is always going to be more exciting than stuff sold by the pound." - Jeremy Clarkson

  12. #11
    Registered User
    Join Date
    Feb 2003
    Posts
    183
    I remember other people having this problem with some detectors. They fixed it by putting a capacitor in the wiring or something like that. Its been over a year ago that I read it though so I don't remember if it was here, nasioc or scoobymods. You may try a search because I know the fix is posted somewhere. Sorry I don't remember the details.
    2002 KY Region Solo II Rookie of the Year
    2003 KY Region Solo II Driver of the Year

  13. #12
    Registered User
    Join Date
    Feb 2004
    Location
    rockledge, fl.
    Posts
    9
    ill try the new plug thing and see how it does

  14. #13
    Registered User bdoug's Avatar
    Join Date
    Aug 2002
    Location
    NE Ohio
    Posts
    1,893
    Originally posted by cnstman
    i have one also and mine does not do it. interesting.

    anyone else?
    THE INTERNET: Where men are men, women are men, and the children are FBI agents.

  15. #14
    Registered User crazycam31's Avatar
    Join Date
    Jul 2003
    Location
    Colorado
    Posts
    2,663
    Originally posted by Salient
    Damn, sounds like a built in rev limiter. Perhaps Escort did it, thinking "if this guy is hitting 5K, then we should scare the **** outta him."

    lol.... sounds like something I'd come up with....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •