200 W amp too much for STI alternator?
+ Reply to Thread
Results 1 to 9 of 9

This is a discussion on 200 W amp too much for STI alternator? within the Interior Mods forums, part of the Tech & Modifying & General Repairs category; Anyone running a 100 W x 2 into 4 ohm amp setup on a STI? Any problems with it drawing ...

  1. #1
    SRR
    SRR is offline
    Registered User SRR's Avatar
    Join Date
    May 2003
    Location
    Denver, CO
    Posts
    51

    200 W amp too much for STI alternator?

    Anyone running a 100 W x 2 into 4 ohm amp setup on a STI? Any problems with it drawing too much current from the alternator?

    The manual on mine says it will draw <20A music avg at 4ohms and <35A with signwave 4ohms a channel. It uses a 30A fuse.

    Thanks
    Scott

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User wonderspark's Avatar
    Join Date
    Aug 2003
    Location
    Lakewood, CO
    Posts
    1,455
    I've been running an 800W amp with no problems.

  4. #3
    Registered User Vendeta2K's Avatar
    Join Date
    Aug 2003
    Location
    Northern California
    Posts
    1,236
    shouldn't cause a problem
    vendeta2k
    Accessport + COBB SF Intake = BEST MOD EVAR!!!!!

  5. #4
    SRR
    SRR is offline
    Registered User SRR's Avatar
    Join Date
    May 2003
    Location
    Denver, CO
    Posts
    51
    Thanks

  6. #5
    Registered User Th3Franz's Avatar
    Join Date
    May 2003
    Location
    Wisconsin
    Posts
    2,766
    Only if your amp is really inefficient. If you don't crank it up loud, don't worry at all. But if it has an efficiency of like 20% and you turn it up, then expect some hefty current draw. But you probably don't have to worry.
    - F r a n z
    Bucky with teh lime powah!

  7. #6
    Registered User happasaiyan's Avatar
    Join Date
    Nov 2002
    Location
    Rolling Meadows, IL
    Posts
    860
    im running a 5 channel with 1200w no prob.
    '04 PSM STi - modded (sr50+the works)
    '05 JGM RSX Type-S - stock

  8. #7
    Registered User Th3Franz's Avatar
    Join Date
    May 2003
    Location
    Wisconsin
    Posts
    2,766
    Once I get my car we'll see how it handles a total of just under 2000 watts RMS.
    - F r a n z
    Bucky with teh lime powah!

  9. #8
    Registered User Tony Soprano's Avatar
    Join Date
    Jul 2002
    Location
    Vancouver USA
    Posts
    19
    I am running an RF 600w and a JBL1200w

    No probs yet

  10. #9
    Registered User Th3Franz's Avatar
    Join Date
    May 2003
    Location
    Wisconsin
    Posts
    2,766
    Originally posted by Tony Soprano
    I am running an RF 600w and a JBL1200w

    No probs yet
    How often do you crank it up all the way? I like to meter my system to see how loud I hit. In my last car, only 135 dB on a TermLab, but once I build a new box, I'm thinking 140 is possible with just two 10's.
    - F r a n z
    Bucky with teh lime powah!

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •