ECU O2 Wires?
+ Reply to Thread
Results 1 to 4 of 4

This is a discussion on ECU O2 Wires? within the Interior Mods forums, part of the Tech & Modifying & General Repairs category; I'm trying to hook up my Apexi TT to the O2 sensor. I have some confusion on what wires the ...

  1. #1
    Registered User Jared's Avatar
    Join Date
    Feb 2002
    Posts
    65

    ECU O2 Wires?

    I'm trying to hook up my Apexi TT to the O2 sensor. I have some confusion on what wires the O2 + and - are. I've read a post stating that the O2 - wire on the ECU is the Red w/ Green stirpe and the O2 + is the White wire which are both on the 2nd plug from the right side of the ECU. The problem I have is there are 3 white wires on that plug. So I've looked and cannot find a WRX service manual in my dumpy little town. Can anyone help on providing which white wire to use?

    Thanks,
    Jared.
    Damn, the Temporal Prime Directive!

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User
    Join Date
    Jun 2002
    Location
    San Diego, CA
    Posts
    27
    I'm in the same boat as you. There's a thread here or on I-Club that says which wire it is. I had it a second ago, but lost it.

    PM me if you want to talk about it. I plan on hooking it up tomorrow.
    2003 Toyota Tacoma Xtra Cab 4x4 V6 w/TRD
    2006 Honda Pilot EX with Leather/Nav
    2002 Acura TL-S (for sale)

    2002 Blue WRX, gone but not forgotten
    2005 WRX STi to be...?

  4. #3
    Registered User
    Join Date
    Jun 2002
    Location
    San Diego, CA
    Posts
    27

    I might have found it..

    Here's a post from BigRich:

    Tapped the B17 (white) wire for the (+) Rear O2 sensor. Also tapped the B17 (red w/ green stripe) for the (-) O2 sensor. These wires are found on the second harness from the right on the ECU. Just be very careful and tape everything back up as it was. Everything seems to be pulling correctly. Just not sure how accurate the #'s are on the Apex unit. But for $100 I can't complain.

    I'm going to look around to confirm this. I'll update what I find, if anything. If anyone else may know, PLEASE post!
    2003 Toyota Tacoma Xtra Cab 4x4 V6 w/TRD
    2006 Honda Pilot EX with Leather/Nav
    2002 Acura TL-S (for sale)

    2002 Blue WRX, gone but not forgotten
    2005 WRX STi to be...?

  5. #4
    Registered User
    Join Date
    Jun 2002
    Location
    San Diego, CA
    Posts
    27
    Correction, BigRich put a new post stating a mistake. The white and black wires from the relay go here:

    White--B17 on connector B135 (middle top connection)
    Black (ground wire)--B19 on B135

    I'm confirming this with him and splicing the wires today. PM me for an update.
    2003 Toyota Tacoma Xtra Cab 4x4 V6 w/TRD
    2006 Honda Pilot EX with Leather/Nav
    2002 Acura TL-S (for sale)

    2002 Blue WRX, gone but not forgotten
    2005 WRX STi to be...?

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •