Horn not working
Results 1 to 5 of 5

This is a discussion on Horn not working within the Interior Mods forums, part of the Tech & Modifying & General Repairs category; Need help, just realized my steering wheel horn is not working. I checked the fuse and its not blown. What ...

  1. #1
    Registered User jroman836's Avatar
    Join Date
    Apr 2003
    Location
    NJ
    Posts
    133

    Horn not working

    Need help, just realized my steering wheel horn is not working. I checked the fuse and its not blown. What could it be ?!? I looked near the kick panel and there's some connectors/relays just hangin there not connected to anything. There is a white one, a black one and two green ones. Could this be a problem?

    I'm not an electrical guru ... please help

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User jroman836's Avatar
    Join Date
    Apr 2003
    Location
    NJ
    Posts
    133
    Anybody ... need help

  4. #3
    Registered User jroman836's Avatar
    Join Date
    Apr 2003
    Location
    NJ
    Posts
    133
    Found the problem ... all is well

  5. #4
    Registered User Th3Franz's Avatar
    Join Date
    May 2003
    Location
    Wisconsin
    Posts
    2,766
    So what was the problem?
    - F r a n z
    Bucky with teh lime powah!

  6. #5
    Registered User jroman836's Avatar
    Join Date
    Apr 2003
    Location
    NJ
    Posts
    133
    Oops sorry, I decided to remove the grill and take a look at the horn and apparently the wire was disconnected. It was just laying there, so I reconnected it back to the horn and wrapped it in electrical tape so it wooudn't come loose again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •