Turbo Timer Problem
+ Reply to Thread
Results 1 to 6 of 6

This is a discussion on Turbo Timer Problem within the Interior Mods forums, part of the Tech & Modifying & General Repairs category; Installed my Blitz FATT today. Has power etc, but for some reason it wont count down. I set it for ...

  1. #1
    Banned Mili727's Avatar
    Join Date
    Jun 2002
    Location
    Ga
    Posts
    3,114

    Turbo Timer Problem

    Installed my Blitz FATT today. Has power etc, but for some reason it wont count down. I set it for 5 minutes and when I shut my car off it just goes red and says 0.00. I had a harness, installed it correctly etc. Anyone know what the problem can be?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User
    Join Date
    Aug 2003
    Location
    Orlando, FL
    Posts
    527
    Did you run the wire to the parking brake?
    Justin
    2003 Sonic Yellow
    NOT STOCK ANYMORE!!

  4. #3
    Registered User Chopaholix's Avatar
    Join Date
    Sep 2003
    Location
    Guasa, Guasa
    Posts
    501

    Re: Turbo Timer Problem

    I got the same one as you did, but how do I install it??? I got the harness to.
    Hecho En Mexico

  5. #4
    Banned Mili727's Avatar
    Join Date
    Jun 2002
    Location
    Ga
    Posts
    3,114
    Originally posted by JrG18m
    Did you run the wire to the parking brake?
    Yes.

  6. #5
    Registered User AjIsDope's Avatar
    Join Date
    Aug 2002
    Location
    SoCal
    Posts
    7,759
    Did you cut the green wire under the drivers side of the dash?
    03 Cobra
    566whp/515wtq

    Pics
    & Dyno
    Pics

  7. #6
    Registered User WRXin''s Avatar
    Join Date
    Jun 2002
    Location
    Houston, TX
    Posts
    8,634
    Okay Jon, you just solved two problems in one hit. You say your brake light flickers on, and that the TT isn't working right eventhough it's tapped into the e-brake wire. Check that wire from start to finish. I'm almost certain now that this is your problem
    Fahd

    Floats like a butterfly and stings like when I pee!

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •