Anyone had a bad Defi Control Unit?
Results 1 to 4 of 4

This is a discussion on Anyone had a bad Defi Control Unit? within the Interior Mods forums, part of the Tech & Modifying & General Repairs category; Well I bought a set of gauges and my installer was working on them yesterday. After testing the wires we ...

  1. #1
    Registered User XtianLA's Avatar
    Join Date
    Nov 2002
    Location
    Los Angeles, CA
    Posts
    606

    Anyone had a bad Defi Control Unit?

    Well I bought a set of gauges and my installer was working on them yesterday. After testing the wires we ran for power and such with a multi-meter like 5 times he diagnosed that the Control Unit was bad. (Note: He has installed Defi setups numerous times)

    It is actually a Control Unit 2. Anways, I sent it back to the Vendor today and they basically said all they can do is test it and send me a new one if it doesn't work.

    Has anyone else had a bad Control Unit? I am hoping that I am a rare case, because just by looking at the product I can tell that it's quality and that it's definitely worth the money I paid for it. I just want to make sure that way I have a little assurance.
    Attached Thumbnails Attached Thumbnails defigauges.jpg  

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User
    Join Date
    Apr 2003
    Location
    CT
    Posts
    584
    Its the only instance ive heard of, maybe it was damaged internally in shipping
    '12 WRB Sedan

  4. #3
    Registered User XtianLA's Avatar
    Join Date
    Nov 2002
    Location
    Los Angeles, CA
    Posts
    606
    hmm....I just hope that I can get a new one without any problems. Thanks 03.

  5. #4
    Registered User
    Join Date
    Nov 2002
    Location
    Northbrook, IL
    Posts
    230
    havent had any problems with mine...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •