boost gauge foging up???!?!?!?!!
+ Reply to Thread
Results 1 to 8 of 8

This is a discussion on boost gauge foging up???!?!?!?!! within the Interior Mods forums, part of the Tech & Modifying & General Repairs category; Has anyone ever had a problem with their boost gauge fogging up? Tonight was the first time that i have ...

  1. #1
    Registered User cloudzero's Avatar
    Join Date
    Apr 2003
    Location
    coshocton, oh
    Posts
    39

    boost gauge foging up???!?!?!?!!

    Has anyone ever had a problem with their boost gauge fogging up? Tonight was the first time that i have ever had this happen.
    I know it was about 88 degress out and Really foggy and muggy, do you think that that could have been the problem?
    WRB '03 WRX
    all the good stuff from STi, COBB, Hotchkis, Perrin, Apex-i, Rota, ScoobySports, and Yokohama

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User AjIsDope's Avatar
    Join Date
    Aug 2002
    Location
    SoCal
    Posts
    7,759
    It's not a problem. Try using a hair dryer to clear it up.
    03 Cobra
    566whp/515wtq

    Pics
    & Dyno
    Pics

  4. #3
    bambams247

    Re: boost gauge foging up???!?!?!?!!

    Originally posted by cloudzero
    Has anyone ever had a problem with their boost gauge fogging up? Tonight was the first time that i have ever had this happen.
    I know it was about 88 degress out and Really foggy and muggy, do you think that that could have been the problem?
    Is it the stock or aftermarket? The stock gauge is poorly built and I'd probably recomend just geting a better aftermarket one instead of trying to figure out the problem with this one.

  5. #4
    Registered User
    Join Date
    Jul 2002
    Location
    Elk Grove Village, IL
    Posts
    275
    I have Autometer gauges and once and a while I'll see some moisture in the gauages but never a full fog. But it only happens early morning and when it's really damp outside with 90% humidity.
    It's not a damn beanbag!

  6. #5
    Registered User cloudzero's Avatar
    Join Date
    Apr 2003
    Location
    coshocton, oh
    Posts
    39

    Smile

    It's the stock gauge, that's mounted on the steering column.
    Maybe it's a sign saying i need to switch it to the Omori set.

    WRB '03 WRX
    all the good stuff from STi, COBB, Hotchkis, Perrin, Apex-i, Rota, ScoobySports, and Yokohama

  7. #6
    Registered User dizastical's Avatar
    Join Date
    Jul 2003
    Location
    Maine
    Posts
    639
    I have an Omori 45mm boost gauge in my driverside air vent and it got fogged up twice . We have had som very bad humidity this year ! I am going to better seal the rear of the gauge where the wires run into it . It does clear up pretty quickly though . Hot glue should work fine . Good luck !
    2004 STI ----- 11.66 @ 125.66 w/ 1.9 60' ----- 537HP/487TQ ----- 93 Octane/Water Injection
    WWW.F1DYNO.COM

  8. #7
    Registered User RLsChMiDt's Avatar
    Join Date
    Dec 2002
    Location
    Cleveland, Ohio
    Posts
    3,891
    Originally posted by cloudzero
    It's the stock gauge, that's mounted on the steering column.
    Maybe it's a sign saying i need to switch it to the Omori set.

    mine's fogged up like 2-3 times... no biggie
    -Ryan |Dub-Yuh Our Ex Ess Tee Eye| My Car

  9. #8
    Banned dark_rex's Avatar
    Join Date
    Aug 2001
    Location
    The Hub
    Posts
    12,157
    mines never fogged up.

    i have a spare guage (no pod or wiring) if you're interested. it's the stock LaMco column mounted one.

    dR

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •