Oil Pressure Guage Adapter, Please Help!
+ Reply to Thread
Results 1 to 8 of 8

This is a discussion on Oil Pressure Guage Adapter, Please Help! within the Interior Mods forums, part of the Tech & Modifying & General Repairs category; Ok, So I have an Autometer Oil Pressure gauge. The plug that you take out (where you want to intall ...

  1. #1
    Registered User NJwrbT-WRX's Avatar
    Join Date
    Apr 2002
    Location
    One Square Mile, NJ
    Posts
    3,250

    Oil Pressure Guage Adapter, Please Help!

    Ok, So I have an Autometer Oil Pressure gauge. The plug that you take out (where you want to intall the the correct adapter) seems to have a non standard thread pattern. It is not 3/8" NPT or 1/2" NPT....I will post some pictures and then ask a question.....

    First pic is on the plug still screwed down.
    Attached Thumbnails Attached Thumbnails 1nutlookingfor.jpg  
    '02 WRB Sedan

    Removed silencer w/ Akimoto Velocity Stack, Blitz Dual TT, Autospeed Prototype Up-pipe w/ Flex-joint, Autospeed Crank Pulley, Autospeed OEM Dead Pedal, Samco IC Hoses, Axxis Pads, Goodridge Lines, Neo Synth Brake Fluid, Speedbleeders, Eibach Pro-Kit, Perrin Endlinks and Rear Sway, 17" Sub Zeros w/ 225/45 ES100s, Crucial Racing Thermostat and 1.4bar Radiator Cap, Autometer Sport-Comp Oil Pressure, EGT, and Voltmeter on the A-Pillar, STI Hoodscoop.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User NJwrbT-WRX's Avatar
    Join Date
    Apr 2002
    Location
    One Square Mile, NJ
    Posts
    3,250
    Here is just the plug.....
    Attached Thumbnails Attached Thumbnails 5picofnutandwasher.jpg  
    '02 WRB Sedan

    Removed silencer w/ Akimoto Velocity Stack, Blitz Dual TT, Autospeed Prototype Up-pipe w/ Flex-joint, Autospeed Crank Pulley, Autospeed OEM Dead Pedal, Samco IC Hoses, Axxis Pads, Goodridge Lines, Neo Synth Brake Fluid, Speedbleeders, Eibach Pro-Kit, Perrin Endlinks and Rear Sway, 17" Sub Zeros w/ 225/45 ES100s, Crucial Racing Thermostat and 1.4bar Radiator Cap, Autometer Sport-Comp Oil Pressure, EGT, and Voltmeter on the A-Pillar, STI Hoodscoop.

  4. #3
    Registered User NJwrbT-WRX's Avatar
    Join Date
    Apr 2002
    Location
    One Square Mile, NJ
    Posts
    3,250
    And here is the pic with the adapter I need. What kind of bushing is that???? It is 1/4" NPT on the female, I know that because that is what the sender is, but what is the male end (the end that is the same as the stock plug??? Do I have to tap the stock plug??

    The adapter has the red box around it. This picture is from scoobymods, so I know the adapter exists, I just need to know what size it is, and where to get it. I can not get it at the hardware store or at the autoparts store.

    Thanks...
    Attached Thumbnails Attached Thumbnails 6picofiolsenderandadapter1 copy.jpg  
    Last edited by NJwrbT-WRX; 04-08-2003 at 08:49 AM.
    '02 WRB Sedan

    Removed silencer w/ Akimoto Velocity Stack, Blitz Dual TT, Autospeed Prototype Up-pipe w/ Flex-joint, Autospeed Crank Pulley, Autospeed OEM Dead Pedal, Samco IC Hoses, Axxis Pads, Goodridge Lines, Neo Synth Brake Fluid, Speedbleeders, Eibach Pro-Kit, Perrin Endlinks and Rear Sway, 17" Sub Zeros w/ 225/45 ES100s, Crucial Racing Thermostat and 1.4bar Radiator Cap, Autometer Sport-Comp Oil Pressure, EGT, and Voltmeter on the A-Pillar, STI Hoodscoop.

  5. #4
    Registered User TurbeauxREX's Avatar
    Join Date
    Mar 2002
    Location
    Des Allemands, La.
    Posts
    1,097

    It's a British Thread

    Sorry, don't recall the size, but it is some goofy (to me) British(?) thread, according to some postings on the old i-club. Try a search on nabisco for oil sender bushing. They listed the part number from Subaru. I will check tonight when i get home. I believe I saved the info on my hard drive.

    Curtis

  6. #5
    Registered User NJwrbT-WRX's Avatar
    Join Date
    Apr 2002
    Location
    One Square Mile, NJ
    Posts
    3,250
    Ok, so I think I have figured it out. The stock plug is BSPT, either 1/2" or 3/8", and the sender is 1/4" NPT. I just need to know exactly what that plug is so I can order the correct adapter from McMaster Carr.

    Thanks to whoever knows.

    -joe
    '02 WRB Sedan

    Removed silencer w/ Akimoto Velocity Stack, Blitz Dual TT, Autospeed Prototype Up-pipe w/ Flex-joint, Autospeed Crank Pulley, Autospeed OEM Dead Pedal, Samco IC Hoses, Axxis Pads, Goodridge Lines, Neo Synth Brake Fluid, Speedbleeders, Eibach Pro-Kit, Perrin Endlinks and Rear Sway, 17" Sub Zeros w/ 225/45 ES100s, Crucial Racing Thermostat and 1.4bar Radiator Cap, Autometer Sport-Comp Oil Pressure, EGT, and Voltmeter on the A-Pillar, STI Hoodscoop.

  7. #6
    Registered User MtnWRX's Avatar
    Join Date
    Dec 2002
    Location
    Amongst the trees & boulders
    Posts
    144
    I just did an oil pressure sender install (and other gauges with Pace's help, THANKS PACE!!) this weekend. The adapter is a Subaru part, PN 11024AA210. See http://forums.nasioc.com/forums/show...ressure+sender for details. It has an 1/8" NPT (National Pipe Thread) female thread. I know you said your sender is 1/4". But, are you aware that an 1/8" pipe thread is actually about 1/4" diameter? The 1/8" refers to the ID of standard pipe, not the thread size. If your sender has the same thread size as the one in the picture, it is 1/8" and the Subaru part should work.

    The sender I had would not fit and I had to tap the adapter out further (NPT's are tapered and the two parts weren't a match stock). Only took my dealer one day to get the part. Good luck.

    Leo
    "Stupid should hurt."

  8. #7
    Registered User NJwrbT-WRX's Avatar
    Join Date
    Apr 2002
    Location
    One Square Mile, NJ
    Posts
    3,250
    Thanks, I got everything sorted out.

    I did mean 1/8" and not 1/4, I had looked at so many adapters and bushings that I was starting to confuse myself. It turns out that the Subaru part has m18 x 1.5 male and 1/8" bspt female, and I ordered the Autometer 1/8 bspt to 1/8 npt adapter, so it looks like I am all set to go.

    -joe
    '02 WRB Sedan

    Removed silencer w/ Akimoto Velocity Stack, Blitz Dual TT, Autospeed Prototype Up-pipe w/ Flex-joint, Autospeed Crank Pulley, Autospeed OEM Dead Pedal, Samco IC Hoses, Axxis Pads, Goodridge Lines, Neo Synth Brake Fluid, Speedbleeders, Eibach Pro-Kit, Perrin Endlinks and Rear Sway, 17" Sub Zeros w/ 225/45 ES100s, Crucial Racing Thermostat and 1.4bar Radiator Cap, Autometer Sport-Comp Oil Pressure, EGT, and Voltmeter on the A-Pillar, STI Hoodscoop.

  9. #8
    Registered User chobits's Avatar
    Join Date
    Nov 2002
    Posts
    606
    is that electrical or mechanical oil pressure?
    i have the same problem with the adapter
    thanks

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •