Oil Pressure Guage Install?
+ Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 17

This is a discussion on Oil Pressure Guage Install? within the Interior Mods forums, part of the Tech & Modifying & General Repairs category; i have the the autometer, phantom, electric oil pressure gauge. Ive had it since december... i cant seem to figure ...

  1. #1
    Registered User pdrpowerofWRX's Avatar
    Join Date
    Aug 2002
    Location
    Springfield, OH.
    Posts
    1,294

    Oil Pressure Guage Install?

    i have the the autometer, phantom, electric oil pressure gauge. Ive had it since december... i cant seem to figure out how to install this and where everything goes.... ive looked on projectwrx.com, but he doesnt really tell how its done. any help would be appreciated. thanks.
    '05 CGM Subaru Impreza WRX Mods
    '02 WRB Subaru Impreza WRX (sold)
    '94 Subaru Legacy Wagon L (daily)
    '90 Toyota Supra Turbo

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User QuickSilver's Avatar
    Join Date
    Jul 2002
    Location
    Bay Area, CA
    Posts
    1,294
    Try scoobymod.com
    It's affiliated w/ NASIOC.com

    Unfortunately it's quite involved to install the oil pressure sender. There are 2 ways described in that site...one attaches the sender to the oil tap under the intercooler and the other taps the same location but connects a hose to the sender mounted on a more convenient location.

    MisterX sugested to me to use the Defi unit which is a sandwich fitting that screws on directly between your oil filter and the engine block. It allow access to the oil to get pressure and/or temp..I'm currently contacting a supplier regarding this.

    Good luck.

    Hg.
    '02 Plat. Wagon, Manual

  4. #3
    Registered User Hot_Dog's Avatar
    Join Date
    Jan 2003
    Location
    Albuquerque, NM
    Posts
    1,329
    Here's the thread on scoobymods
    http://www.scoobymods.com/forums/sho...p?threadid=612

    I installed my oil temperature sensor in this spot. There is not a lot of room to work in this area. I would follow the advice on that thread and get a crows foot wrench. My temp sensor was small, so I could use an open ended wrench, but by the time I was done, I was bleeding all over.

    BTW, the hex key to get the plug off is 8mm.
    2003 WRB Sedan. Mods & Pics

    Quote Originally Posted by scooby-x
    OMG!!! Do you want me on my knees or bent over? I love you

  5. #4
    Registered User dddnuts's Avatar
    Join Date
    Jan 2003
    Location
    Putnam Valley, NY
    Posts
    121
    Do you happen to know the adapter size or part number and where I could get it? Would a local parts store carry something like that or do I have to order from Autometer? Thanks in advance.

  6. #5
    Registered User Hot_Dog's Avatar
    Join Date
    Jan 2003
    Location
    Albuquerque, NM
    Posts
    1,329
    I have no clue. Dan at godspeed sent mine along with the gauges. If you can't find the answer, maybe send him an e-mail.
    2003 WRB Sedan. Mods & Pics

    Quote Originally Posted by scooby-x
    OMG!!! Do you want me on my knees or bent over? I love you

  7. #6
    Registered User pdrpowerofWRX's Avatar
    Join Date
    Aug 2002
    Location
    Springfield, OH.
    Posts
    1,294
    cool. thanks for the help fellow WRXers! ill try it and if it doesnt work ill go for the defi sandwich thing that misterX tried.
    '05 CGM Subaru Impreza WRX Mods
    '02 WRB Subaru Impreza WRX (sold)
    '94 Subaru Legacy Wagon L (daily)
    '90 Toyota Supra Turbo

  8. #7
    Registered User pdrpowerofWRX's Avatar
    Join Date
    Aug 2002
    Location
    Springfield, OH.
    Posts
    1,294
    ok, ok, i must be a fool. there are the wires in the back... the black and white for the light bulb (white=power and blk=ground), got it, then there is the wire from the sender unit to the back of the gauge, got that one too, but there are also another for ground and another for power. where would i send these wires? can i just splice them into the light bulbs power and ground source? or do i have to run to another souce of power... which one, the ignition? and run the ground to the engine compartment? what engine ground would work best?
    thanks.
    '05 CGM Subaru Impreza WRX Mods
    '02 WRB Subaru Impreza WRX (sold)
    '94 Subaru Legacy Wagon L (daily)
    '90 Toyota Supra Turbo

  9. #8
    Registered User dddnuts's Avatar
    Join Date
    Jan 2003
    Location
    Putnam Valley, NY
    Posts
    121
    In response to your ground question, I'm grounding everything to a screw right under the dash that is connected to the frame of the car. The power supply is another story. I believe that you want to send this one to a separate power supply. If anyone knows more about this I'd appreciate it too.

  10. #9
    Registered User pdrpowerofWRX's Avatar
    Join Date
    Aug 2002
    Location
    Springfield, OH.
    Posts
    1,294
    anyone? anyone?
    '05 CGM Subaru Impreza WRX Mods
    '02 WRB Subaru Impreza WRX (sold)
    '94 Subaru Legacy Wagon L (daily)
    '90 Toyota Supra Turbo

  11. #10
    Registered User Hot_Dog's Avatar
    Join Date
    Jan 2003
    Location
    Albuquerque, NM
    Posts
    1,329
    I think you would run the power off the ignition. You only want the gauge to be on when the car is on. If you tied it into the same wire as the light bulb, then the gauge would only be on when the lights are on.

    All the ground wires can go to the same spot though.
    2003 WRB Sedan. Mods & Pics

    Quote Originally Posted by scooby-x
    OMG!!! Do you want me on my knees or bent over? I love you

  12. #11
    Registered User pdrpowerofWRX's Avatar
    Join Date
    Aug 2002
    Location
    Springfield, OH.
    Posts
    1,294
    ok, cool. then ill try and find the right wire.
    '05 CGM Subaru Impreza WRX Mods
    '02 WRB Subaru Impreza WRX (sold)
    '94 Subaru Legacy Wagon L (daily)
    '90 Toyota Supra Turbo

  13. #12
    Registered User dddnuts's Avatar
    Join Date
    Jan 2003
    Location
    Putnam Valley, NY
    Posts
    121
    pdrpowerofwrx let me know when you find it. I'm not at that point yet. I only have about 1 hr of daylight a day to work on it and no garage so I'm crawling along here.

  14. #13
    Registered User pdrpowerofWRX's Avatar
    Join Date
    Aug 2002
    Location
    Springfield, OH.
    Posts
    1,294
    hey dd... i couldnt get to the ignition wire part of the install, because i messed up on a part of the install....
    i removed the oil thing with the 8 mm hex wrench and then i went to install my adapter for my pressure sensor... the darn thing is too small... so i searched and searched, but no one had a right sized piece to put in there....
    so, i got a 7/16" drill bit and drilled out the center of the above piece... then used a tap to tap it.... i was almost through when the darn tap snapped off!!! so i ruined the piece.... i had to order a new piece from SOA and itll be here on Friday morning... im then going to take it and have it professionally drilled and tapped. i also bought an extra piece in case i mess this one up.
    dd, how did you install the senser? in the same why as me, as described on scoobymods.com? let me know where you tapped the wire for the power for the gauge, not the light. thanks.
    '05 CGM Subaru Impreza WRX Mods
    '02 WRB Subaru Impreza WRX (sold)
    '94 Subaru Legacy Wagon L (daily)
    '90 Toyota Supra Turbo

  15. #14
    Registered User dddnuts's Avatar
    Join Date
    Jan 2003
    Location
    Putnam Valley, NY
    Posts
    121
    Yeah that thread was very helpful. I still need to go buy the crows foot wrench and I won't be able to work on it until this Sunday. I bought a whole mess of adapters as I tried long and hard to figure out the proper size. Again I won't know until Sunday if any of these fit, if not I'm going to try tapping that original fitting. I went out and bought fuse taps which I also need to modify slightly to get them to fit. Oh well. Nobody said this was easy right? I'm going to tap into the ignition for the power. Keep me up to date on how you make out and I'll do the same. I'll also try to get pictures up and post a size on that adapter if it fits. Thanks, Good Luck Chris

  16. #15
    Registered User pdrpowerofWRX's Avatar
    Join Date
    Aug 2002
    Location
    Springfield, OH.
    Posts
    1,294
    i tapped my first fitting and i broke the tap off inside of it... so i ordered two more of those things from my Subaru. so im going to pick them up right now and then take one of them to get it tapped by an engine builder.
    if that doesnt work, then i have the extra one to run till i figure out how to put it in. also, check out projectwrx.com for the wiring part of the install.
    good luck
    '05 CGM Subaru Impreza WRX Mods
    '02 WRB Subaru Impreza WRX (sold)
    '94 Subaru Legacy Wagon L (daily)
    '90 Toyota Supra Turbo

+ Reply to Thread
Page 1 of 2 12 LastLast

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •