Blinker and Brights
+ Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 21

This is a discussion on Blinker and Brights within the Interior Mods forums, part of the Tech & Modifying & General Repairs category; I am having a problem with my blinker. Every time I swich on the blinker it flashes the brights on ...

  1. #1
    Banned
    Join Date
    Jun 2007
    Location
    Great Salt City of Utah
    Posts
    0

    Lightbulb Blinker and Brights

    I am having a problem with my blinker. Every time I swich on the blinker it flashes the brights on and off. If I am gentile and don't swich it all the way over, it doesn't trip. I need to get this fixed before some crazy person thinks the cops a going to be after them. Plus the constant swiching on and off can't be good for what ever relay is kicking on and off. I don't have a boost gauge on the steering column or I would have looked at that. It just started happening.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User GateWRXING's Avatar
    Join Date
    Oct 2006
    Location
    NJ/NY
    Posts
    996
    Perhaps your car is possesed. An exorcism maybe?
    gJb Hawk-Eye Alliance #002

    Mets
    Giants
    Rangers

  4. #3
    Banned
    Join Date
    Jun 2007
    Location
    Great Salt City of Utah
    Posts
    0
    Oh snap

    Mabey it want's it's cats back.

  5. #4
    Registered User GateWRXING's Avatar
    Join Date
    Oct 2006
    Location
    NJ/NY
    Posts
    996
    It knows all. And it's coming for revenge.
    gJb Hawk-Eye Alliance #002

    Mets
    Giants
    Rangers

  6. #5
    Banned
    Join Date
    Jun 2007
    Location
    Great Salt City of Utah
    Posts
    0
    Blink Blink- Anyone

  7. #6
    Banned
    Join Date
    Jun 2007
    Location
    Great Salt City of Utah
    Posts
    0
    bumpid

  8. #7
    Registered User ntg06's Avatar
    Join Date
    Nov 2006
    Location
    MSG
    Posts
    160

  9. #8
    Banned
    Join Date
    Jun 2007
    Location
    Great Salt City of Utah
    Posts
    0
    This problem is making me unhappy It's going to get me pulled over.

    It turns out the brights are not coming on. Instead the lights are just shuting on and off. Every time I use the blinker the lights turn off.
    The daytime runing lights are left on. I am starting to wonder if somone had tryied to do a daytime runing light mod or fog light mod and messed it up.

  10. #9
    Registered User Thug Nasty's Avatar
    Join Date
    Jul 2006
    Location
    Denver CO / Portland OR
    Posts
    185
    lol you have to admit it is kinda a funny problem. I mean, it could be way worse. Goodluck and sorry I dont have anything positive to contribute lol.
    -John
    Different Strokes
    Dirty Crew #2002
    Mods in profile.

  11. #10
    Banned
    Join Date
    Jun 2007
    Location
    Great Salt City of Utah
    Posts
    0
    It's getting worse and worse. Every day it gets worse.

  12. #11
    Banned
    Join Date
    Jan 2007
    Location
    Dirtee Jersee
    Posts
    0
    Look at your fuse box. any strange wires running in there? did you take plastic away from the steering column and look at the switches? frayed wire? short somewhere? Have you looked at anything yet or just come running to the forums? ;-)

  13. #12
    Banned
    Join Date
    Jun 2007
    Location
    Great Salt City of Utah
    Posts
    0
    Haven't seen any

    There's a notiable clicking coming from the pasenger side on the car.

  14. #13
    Banned
    Join Date
    Jan 2007
    Location
    Dirtee Jersee
    Posts
    0
    Quote Originally Posted by Not-EWRX View Post
    Haven't seen any

    There's a notiable clicking coming from the pasenger side on the car.
    oh man, i know what that is....

  15. #14
    Registered User
    Join Date
    Jun 2007
    Location
    eprov rhode island
    Posts
    200
    you ABSOLUTELY POSITIVELY need a combonation switch..without a doubt..seen that prob many times...i believe on your car you can get just the turn signal side of it..if so thats all you need...dont bother wasting time trying anything else..you need one...replace it..its the only fix...your welcome
    New England F4

    feel free to pm me with any questions..

  16. #15
    Banned
    Join Date
    Jun 2007
    Location
    Great Salt City of Utah
    Posts
    0
    Hey is the part pictured here


+ Reply to Thread
Page 1 of 2 12 LastLast

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •